Forum Xamarin.Android
We are excited to announce that the Xamarin Forums are moving to the new Microsoft Q&A experience. Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

We encourage you to head over to Microsoft Q&A for .NET for posting new questions and get involved today.

Using VS 15.6.4 but can not install Support library v27.0.2 because of Mono.Android version

Hi,

I'm using latest version of VS (15.6.4), and I want to add Xamarin.Android.Support.v4 latest version (27.0.2), but I got this error:

Could not install package 'Xamarin.Android.Support.v4 27.0.2'. You are trying to install this package into a project that targets 'MonoAndroid,Version=v8.0', but the package does not contain any assembly references or content files that are compatible with that framework. For more information, contact the package author.

How I can fix this problem?

Best Answers

  • MehdiDehghaniMehdiDehghani USMember ✭✭
    Accepted Answer

    I could fix the problem, seems like deleting posts is not possible here, so sorry for posting this question

  • MehdiDehghaniMehdiDehghani USMember ✭✭
    Accepted Answer

    Hi,
    You need to update Android SDK to v27.x. after that Visual Studio will automatically point to MonoAndroid 8.1

    Hope this helps

Answers

  • MehdiDehghaniMehdiDehghani USMember ✭✭
    Accepted Answer

    I could fix the problem, seems like deleting posts is not possible here, so sorry for posting this question

  • zjmskytestzjmskytest USMember ✭✭

    Hi,I have same problem,how do you fixed this problem? Thanks!

  • MehdiDehghaniMehdiDehghani USMember ✭✭
    Accepted Answer

    Hi,
    You need to update Android SDK to v27.x. after that Visual Studio will automatically point to MonoAndroid 8.1

    Hope this helps

Sign In or Register to comment.