Forum Xamarin.Forms

Xamarin forms iOS crashes due to signing issue

Xamarin forms iOS crashes due to signing issue

I'm having problems deploying my Xamarin forms apps to iOS. Sometimes it works sometimes it doesn't. The following code signature missing error (or similar) seems to always be the problem.
If I rebuild, then it will work, but if I rename the solution FOLDER, it will crash again.
If I make a copy of the entire folder with my solution in it and run it without changes it will crash.
Sometimes it will just hang with the "white" splash screen.

The simulators and android always works.
This is happening with not just one project.
My iOS swift projects do no have this problem. I am using the same developer account.

I tried changing the build instruction set from arm64 to something else. I've tried simplifying the code.

=====
Launched application 'com.mycompany.aaa’ on ‘my iPhone' with pid 677
dyld: Library not loaded: rpath / libmonosgen-2.0.dylib
Referenced from: aaa.iOS.app / aaa.iOS
Reason: no suitable image found. Did find:
aaa.iOS.app / libmonosgen-2.0.dylib: required code signature missing for 'aaa.iOS.app / libmonosgen-2.0.dylib'

Application 'com.mycompany.aaa' terminated.

====
My development environment is thus:

=== Visual Studio Community 2017 for Mac ===

Version 7.4.2 (build 12)
Installation UUID: 53fcefff-1737-4a8d-9526-5f7eb9f7363b
Runtime:
Mono 5.8.1.0 (2017-10/6bf3922f3fd) (64-bit)
GTK+ 2.24.23 (Raleigh theme)

Package version: 508010000

=== NuGet ===

Version: 4.3.1.4445

=== .NET Core ===

Runtime Versions:
2.0.5
2.0.3
SDK Versions:
2.1.4
2.0.3

=== Xamarin.Profiler ===

Version: 1.6.1

=== Xamarin.Android ===

Version: 8.2.0.16 (Visual Studio Community)
Android SDK:
Supported Android versions:
2.3 (API level 10)
5.0 (API level 21)
7.1 (API level 25)
8.0 (API level 26)
8.1 (API level 27)

SDK Tools Version: 26.1.1
SDK Platform Tools Version: 27.0.1
SDK Build Tools Version: 27.0.3

Java SDK: /usr
java version "1.8.0_131"
Java(TM) SE Runtime Environment (build 1.8.0_131-b11)
Java HotSpot(TM) 64-Bit Server VM (build 25.131-b11, mixed mode)

Android Designer EPL code available here:
xamarin / AndroidDesigner.EPL

=== Xamarin Inspector ===

Version: 1.4.0
Hash: b3f92f9
Branch: master
Build date: Fri, 19 Jan 2018 22:00:34 GMT
Client compatibility: 1

=== Apple Developer Tools ===

Xcode 9.3 (14154)
Build 9E145

=== Xamarin.Mac ===

Version: 4.2.1.28 (Visual Studio Community)

=== Xamarin.iOS ===

Version: 11.9.1.24 (Visual Studio Community)
Hash: f62de472
Branch: xcode9.3
Build date: 2018-03-29 19:30:53-0400

=== Build Information ===

Release ID: 704020012
Git revision: 0d8e3f0a4d683771f17959739956fa09c7ba21e3
Build date: 2018-03-30 10:45:17-04
Xamarin addins: 958839ea56ab1e331caf7c92b6ad50fb9e6ee9d2
Build lane: monodevelop-lion-d15-6

=== Operating System ===

Mac OS X 10.13.4
Darwin 17.5.0 Darwin Kernel Version 17.5.0
Mon Mar 5 22:24:32 PST 2018
root:xnu-4570.51.1~1 / RELEASE_X86_64 x86_64

=== Enabled user installed addins ===

Internet of Things (IoT) development (Preview) 7.1

Best Answer

Answers

  • stevehunterstevehunter Member ✭✭

    Thanks for the reply. I do have a wildcard appID and the several programs I have do work - intermittently. That is, if I change the solution folder name, or do a rebuild without altering the code it will fail or succeed. That's what makes it frustrating.

  • stevehunterstevehunter Member ✭✭

    I found two issues. First is that I had to use manual provisioning as automatic provisioning wasn't working when I first installed VS for Mac. I.e. it didn't give me any choice to select a team when I logged in. Now it does after updating VS for Mac and xcode from 9.2 to 9.3 .

    Second, for some unknown reason, if I try to create an object (mine was App.settingsModel = new settingsModel(); prior to setting MainPage() it would freeze at the white splash screen. Could not step beyond that statement.

Sign In or Register to comment.