Linking error when adding AppCenter NuGet packages

gilleslebgillesleb Member ✭✭
edited March 2018 in Xamarin.iOS

Hello,

My application under info.plist has a Deployment Target of 9.0.
In my packages.config (for NuGet) the TargetFramework is xamarinios10.

I am trying to add the Microsoft AppCenter NuGet packages, which according to the documentation are for targeting devices running iOS 9 or later.
As soon as I had those packages I get a lot of errors of the kind:
"Error MT5209 : Native linking error : warning: object file (.../.../foo.o)) was built for newer iOS version (10.1) than being linked (9.0)".

I have later found out I don't get any errors if I only include the base AppCenter or the AppCenter.Analytics packages, only the AppCenter.Crashes package.

If I remove those NuGet packages the errors go away.
What is happening here?

Tagged:

Best Answer

  • gilleslebgillesleb ✭✭
    Accepted Answer

    I found the source of my problem. It was a conflict with the Hockey App package. This conflict was mentioned in the AppCenter documentation.

Answers

  • gilleslebgillesleb Member ✭✭
    Accepted Answer

    I found the source of my problem. It was a conflict with the Hockey App package. This conflict was mentioned in the AppCenter documentation.

Sign In or Register to comment.