Cannot target .NET Standard 2.0 in VS/Xamarin

ZoliZoli NLMember ✭✭✭

I have VS15.5.6 installed.
.NET 4.7.02053
Xamarin 4.8.0.760

When I create a new .NET Standard Xamarin project, the "Target framework" field is empty. If I click, I see 1.0 - 1.1 - 1.2 - ... - 1.6.
But no 2.0
So I installed: dotnet-sdk-2.1.4-windows-x64-installer
Then I downloaded .NET Core SDK 2.0.3. (this one is not an installer, so I just copied the zip/sdk/2.0.3 folder -> "c:\Program Files\dotnet\sdk\2.0.3" )

Restarted VS, but I still only see 1.0 - 1.6 .NET Standard.

Why cannot I target 2.0?

Tagged:

Best Answer

  • ZoliZoli NL ✭✭✭
    Accepted Answer

    Sorry, that is VS2017, Version 15.5.6

    In the meanwhile, I found the reason: invalid char I had in my %PATH% env. variable.
    THIS(!!) caused the issue, now I can see 2.0 as well.

Answers

  • JohnHJohnH GBMember ✭✭✭✭✭

    @Zoli, my understanding is that VS2015 will only support up to 1.6. You will need to upgrade to VS2017.

  • ZoliZoli NLMember ✭✭✭
    Accepted Answer

    Sorry, that is VS2017, Version 15.5.6

    In the meanwhile, I found the reason: invalid char I had in my %PATH% env. variable.
    THIS(!!) caused the issue, now I can see 2.0 as well.

  • JohnHJohnH GBMember ✭✭✭✭✭

    @Zoli said:
    Sorry, that is VS2017, Version 15.5.6

    Urgh, my bad, thanks for posting the solution you found though.

Sign In or Register to comment.