Intellisense problem in Visual Studio

2»

Answers

  • PaulLambertiPaulLamberti USMember ✭✭
    edited February 2017

    When i say "chime" i mean provide an answer. Is there an answer to this issue? This thread continues with no conclusion (answer). Why do I need to start a new thread. Your last comment was back in April and people continued to have issues. The person that commented right before me has the exact same issue. If there is no solution, telling me there is no solution would be the next best thing so I can inform my supervisor why there's been no progress.

    Please Help.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai
    edited February 2017

    General internet forum etiquette is to post a new thread rather than reusing a thread that is getting old, especially when there is ambiguity in the results where certain steps have been reported to work for many users but not for others. The new thread can then focus on the particular environment of that particular author. If the steps from April 5 and April 20 don't help in your particular case, nor does deleting the .suo file, nor does disabling ReSharper (if applicable), then it is also entirely possible that a new bug report will be appropriate. In that case, please be sure to include as many details as possible (see also the bug filing guide) about what might be unique to your environment compared to the other users in this thread. Thanks in advance!

    (The idea to submit a new forum thread or Stack Overflow question would be get some preliminary help from the broader community on potential tips to try in troubleshooting the issue in your particular environment, with the hope that your particular environment is not "unavoidably" unable to get IntelliSense working due to a bug in Xamarin (which could always be the case, but is perhaps a bit unlikely in this particular instance). Based on the number of other users on this thread who have had some success getting IntelliSense working one way or another, there is some hope that walking through the steps another user followed from installation to getting IntelliSense working would work in your case too.)


    Cross-reference for general guidelines:

  • Basit-ABKBasit-ABK USMember

    @BrendanZagaeski said:
    To mention 2 quick notes that might be useful, in particular related to XAML IntelliSense (I indirectly assume that XAML IntelliSense is indeed the topic of this question based on the mention of "an extension from vs gallery"):

    1. Bug 38829 - Suspending ReSharper is currently not sufficient to re-enable the Xamarin.Forms IntelliSense extension. So if you have ReSharper installed but suspended, you will not get XAML IntelliSense. But there is a workaround (see 2).

    2. In my tests with VS 2015 Update 1, the "Enable XAML Language for Xamarin.Forms" extension had no effect on the behavior of the XAML IntelliSense. Workaround: I was able to achieve the desired behavior where the <?xml version="1.0" encoding="utf-8" ?> line was all blue (as shown in the screenshots on the page for the extension) by right-clicking the XAML file in the Solution Explorer and selecting "Open With... > Source Code (Text) Editor". This workaround gave me the desired XAML IntelliSense even without installing the extra "Enable XAML Language for Xamarin.Forms" extension and even with ReSharper installed but suspended.

      image

    This worked for me. Thanks @BrendanZagaeski

  • nmdiasnmdias USMember ✭✭

    @PaulLamberti said:
    I finally got intellisense to work. I also figured out why the previous posts did not work for me. Intellisense worked for me if you following the following steps exactly:

    1) Create a new Forms Xaml Page.
    2) It will automatically open, you must close it immediately WITHOUT SAVING!
    3) Right click the file and "Open with..." Source Code (Text) Editor (as described in the previous posts).
    4) The first line should be all blue (???) and intellisense should now work.

    Note, if after step1 one you save it (in the default editor), intellisense will never work. If you delete the file and recreate the file with the exact same name, it will also never work. If you make this mistake of saving the xaml file in the default editor, you must delete the file and recreate it with another name.

    If you at any point during your project, edit the file using the default editor and save it, intellisense will never work for the file even if you open it with the specific editor.

    Microsoft/Xamarin really needs to fix this.

    Oh my god, Thank You! I had this issue for so long...

    On top of that, the .cs files wouldn't expand. Whenever that happens, I know I'm in trouble. This also fixed that.

  • JeanBosseJeanBosse USMember

    None of the solutions seemed to work until I updated to the latest Xamarin.Forms package 2.3.3.180 referenced in the PCL. I suspect people were getting mixed results based on what packages were installed in VS. My PCL packages where an old version was installed created squiggly lines in the XAML editor after choosing the Open With... Source Code (Text) Editor option. I did not test how far back it was fixed but best to have the latest stable version installed. It might have been a fluke for me, but hopefully it helps someone.

    Note: an older version of Xamarin.Forms in platform specific projects appears to be ok and not break intellisense.

    My build is VSCommunity 2015 Upd3 with Xamarin 4.2.2.11 and Installed Xamarin.Forms 2.3.3.180 in the PCL Reference

  • What also worked for me is change the "build action" of a .xaml page

    this can be done at right click xaml page -> properties -> Build Action -> change it to something else and back

  • @StefanVerduijn.9711 Thanks! That helped. Everytime I do something with Xamarin I am wondering why there are still so many stupid bugs.

  • AkatsukiDiabloAkatsukiDiablo USMember

    @StefanVerduijn.9711 said:
    What also worked for me is change the "build action" of a .xaml page

    this can be done at right click xaml page -> properties -> Build Action -> change it to something else and back

    This worked perfectly

  • AvinashNaimpallyAvinashNaimpally USMember ✭✭

    @nmdias said:

    @PaulLamberti said:
    I finally got intellisense to work. I also figured out why the previous posts did not work for me. Intellisense worked for me if you following the following steps exactly:

    1) Create a new Forms Xaml Page.
    2) It will automatically open, you must close it immediately WITHOUT SAVING!
    3) Right click the file and "Open with..." Source Code (Text) Editor (as described in the previous posts).
    4) The first line should be all blue (???) and intellisense should now work.

    Note, if after step1 one you save it (in the default editor), intellisense will never work. If you delete the file and recreate the file with the exact same name, it will also never work. If you make this mistake of saving the xaml file in the default editor, you must delete the file and recreate it with another name.

    If you at any point during your project, edit the file using the default editor and save it, intellisense will never work for the file even if you open it with the specific editor.

    Microsoft/Xamarin really needs to fix this.

    Oh my god, Thank You! I had this issue for so long...

    On top of that, the .cs files wouldn't expand. Whenever that happens, I know I'm in trouble. This also fixed that.

    After hours of frustration, this worked like a charm!
    @PaulLamberti, you are the man!
    Thanks so much.

  • sureshrajanasureshrajana USMember ✭✭

    @purvin

    This two steps worked for me:
    1. Delete obj folder ( to remove ...g.cs files)
    2. Clean project

    where can apply the steps
    which obj folder can i delete....

  • sureshrajanasureshrajana USMember ✭✭

    [email protected]

    i have problem with xaml Intellisense in xamarin.froms shared project

    i saw your post regarding to xaml Intellisense
    but i don't understand the process can you show me he screen shot of the following steps .......

    "Delete obj folder ( to remove ...g.cs files)
    Clean project
    Comment all your Xaml between opening root tags ( keep the root tag) i.e don't comment root tags.
    Comment all code in code behind except the constructor call of InitializeComponent()
    Rebuild it."

  • sureshrajanasureshrajana USMember ✭✭

    @purvin

    *can you show me the screen shot of following steps

  • shortRevoltshortRevolt USMember ✭✭

    @SerkanDede.1340 said:

    @dpedrinha said:
    @BrendanZagaeski But now I'm getting a lot of "The type 'ContentPage' could not be found... Check if it's not missing an assembly..." message for every item. Keep having to rebuild it to fix.

    Check the VS dropdown. @BrendanZagaeski's solution works for me after edit this.

    Thank you.
    It Worked..... Thanks

  • OlivierPavlinOlivierPavlin USMember

    Hi, for those who have still some trouble with Intellisense in xaml file and have a UWP project in there solution, see this post https://forums.xamarin.com/discussion/comment/269884#Comment_269884

  • JeffGonzalesJeffGonzales USMember ✭✭

    For what it's worth, my red squigglies went away by doing the following:

    1. Right-click on the offending project in the Solution Explorer.
    2. Choose "Unload Project" in the context menu.
    3. Right-click on the same project again.
    4. Choose "Reload Project" in the context menu.
  • HakanALTINDISHakanALTINDIS USMember

    @GirishPande said:
    by deleting .suo file we can get the intellisense back ;)

    It is absolutely work. Thanks a lot @GirishPande

  • SuatKorkmazSuatKorkmaz USMember ✭✭✭

    @JeffGonzales said:
    For what it's worth, my red squigglies went away by doing the following:

    1. Right-click on the offending project in the Solution Explorer.
    2. Choose "Unload Project" in the context menu.
    3. Right-click on the same project again.
    4. Choose "Reload Project" in the context menu.

    Thanks for the tip. It worked for me.

  • HarshHarsh Member

    This worked for me:
    1. Open Resharper menu.
    2. Click on 'Options'.
    3. Click on 'Intellisense'.
    4. Click on 'General'.
    5. Change the radio button from Resharper to Visual studio.

  • rajput400rajput400 Member

    @Harsh said:
    This worked for me:
    1. Open Resharper menu.
    2. Click on 'Options'.
    3. Click on 'Intellisense'.
    4. Click on 'General'.
    5. Change the radio button from Resharper to Visual studio.

    Thanks buddy !
    this one worked perfectly, I almost tried every possible thing in the above mentioned posts nothing worked until I made my mind to try the last one and here it is Hip Hip Hurrayy....

  • joscojosco Member ✭✭

    Fortunately I am using git for source control. my solution was put all in a stash then I realize that the autocomplete function came back then I added all the changes from the stash manually in the project and the autocomplete problems were fixed.

  • CatdriverCatdriver Member

    Thanks @BrendanZagaeski ....

Sign In or Register to comment.