Forum General

Archive Distribute Button not Working

alwydlalwydl Member ✭✭

After I made the update for Xamarin yesterday, the button Distribute in the Archive Manager simply don't answer. It is like it is not enabled.
My project builds fine, without errors, also no error is displayed during archive process and there are no build comments.
I`m using VS 2015 Community Version 14.0.25431.01 update 3.

The only different thing I noticed, is that when I open a project, it shows a message that Components are not supported anymore, to migrate to nugets. I already deleted the components everywhere (project, folder and appData/xamarin/cache/Components) and the message still shows.

Anyone knows how to proceed?


  • EmilAlasgarovEmilAlasgarov AZMember

    I confirm, I have the same problem. And the same versions of Xamarin and VS.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    GitHub Issues cross-reference

    To summarize the latest status of that issue briefly, the team is working on a fix. One thing to note is that the local testing by the team so far indicates that the problem does not affect Visual Studio 2017 (and in general the team does recommend updating to Visual Studio 2017), so if it's possible for your use case, updating Visual Studio 2017 would be one way to avoid the issue. I'll also message the 2 of you links to the previous version of the Visual Studio 2015 Tools for Xamarin installer in case you'd like to switch back to that version temporarily. (The download links for that previous version on the downloads page will also be updated soon. That's just pending a website deployment refresh.)

  • I'm also encountering this issue (the Distribute button doesn't do anything) with VS2015 since I updated the Xamarin Tools.

    Unfortunately I can't get my project working in VS2017.

  • MarcusIMarcusI SEMember ✭✭

    I have the same issue. Using VS 2015 Community.

  • Federico787878Federico787878 USMember ✭✭

    I have the same problem. what happened is very serious. my client asked me to generate apk and I could not do it because of this update. since March 6th, 15 days have passed but I do not see any update to solve this. .I can not use vss 2017. when do you solve it? it is very urgent

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai
    edited March 2018

    I would recommend to follow the corresponding GitHub issue for the latest information on this problem. I will copy some information from that issue here about a manual signing and distribution approach that might be helpful for some users who come across this forum thread first.

    For users who are unable to switch back temporarily to the previous version of the Visual Studio 2015 Tools for Xamarin until a fix is available, note that it is also possible to complete the signing and distribution process manually:

  • PrasanthKumarPrasanthKumar INMember ✭✭

    Hi Brendan,
    I've tried to follow your steps to sign the APK manually with the steps provided. Am getting the below exception.

    -Djava.ext.dirs=C:\Program Files (x86)\Android\android-sdk\build-tools\27.0.3\lib is not supported. Use -classpath instead.
    Error: Could not create the Java Virtual Machine.
    Error: A fatal exception has occurred. Program will exit.

    Please suggest the alternative to distribute the Xamarin.Android package.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    -Djava.ext.dirs=C:\Program Files (x86)\Android\android-sdk\build-tools\27.0.3\lib is not supported. Use -classpath instead.

    That error didn't look familiar to me, so I tried a quick web search, and I found

    Based on that post, it sounds like you might have Java JDK 9 or Java JRE 9 installed. You will want to have just one version of Java JDK 8 installed for the best results when using the Android tools.

  • JulioHTP1JulioHTP1 Member

    Any news of repair? I can't update and have already generated, before, sign to the application. Should I manually sign?

  • dlopmentdlopment USMember ✭✭
    edited June 2018

    I have the same issue. Using Microsoft Visual Studio Enterprise 2015 and Xamarin
    Any news of repair?

  • anveanve DEMember ✭✭✭

    This is the next bug I encounter and Microsoft doesn't provide a fix for months ... I want to distribute my apk and not buy VS 2017. Also this is a process which takes time and can't be done right now.

  • PeterMidgleyPeterMidgley USMember ✭✭

    I am finding on windows 10 the same issue (vs2015, xamarin whereas on windows 7 the distribute button is working.
    Is there by now a fix for this please?

Sign In or Register to comment.