Forum Visual Studio

Using Vs 2017 Android virtual device - Google Play Services mut supported on your device

davefxydavefxy Member ✭✭

I am debugging a Xamarin Forms Net Standard 2 app using the Arndroid_Arm_Nougat. The app loads and runs fine until I select a contentpage containg the map control. Then the app displays this error: wont run without Google Play Services, which are not supported on this device.
This is my first foray into the crossdevelopment Xamarin world and my first Android test app. The UWP version works fine. Do I somehow add the Google Play services to the emulator? I have also tried to run the FormsGallery sample on the emulator with the same results. Do I use a different emulator?

Best Answers


  • davefxydavefxy Member ✭✭

    Alright I can do that. Where can I find this info on how to download and debug the VS 2017 cross-platform android app on a physical device?

  • davefxydavefxy Member ✭✭

    I apologize for requiring so much hand holding. I plugged my Galaxy Tab S2 into a USB port. How do I get this device to show up in the dropdown

  • ClintStLaurentClintStLaurent USUniversity ✭✭✭✭✭

    Did you install the Samsung mobile device driver to your development PC?

  • davefxydavefxy Member ✭✭

    OK I got it working with a USB attached Tab S2. Thanks. Had to play with attaching/re-attaching device until got prompt for debugging on the Tab.

  • davefxydavefxy Member ✭✭

    I have spent last 2 days trying to get an android environment that would load the map control. I tried the emulators and the Live Player. Since this was my first time developing an android app I was assuming all of the issues were my lack of knowledge coding for the Android environment. While this is still true, getting the testing set up to use a USB connection to the Tab S2 lets me get back to developing an app. I am so happy I found this forum. Now back to getting my UWP app translated to Xamarin forms.

Sign In or Register to comment.