Xamarin forms IOS part - FCM can't open GoogleService-Info.plist

Hi everyone,

I have a weird issue. I'm trying to configure a FCM service for notifications. The IOS part consist on add GoogleService-Info.plist in the project. Change the build action into Bundle Ressource.

And after that, I can't open this plist from Visual studio

Is it normal ? Do I have to configure it with a text editor ?

Many thanks for your answers.



  • BehroozTorkiBehroozTorki HUMember ✭✭
    edited March 2018

    I found the problem and is very stupid.

    1 - Open "GoogleService-Info.plist" file in an editor
    2 - change any tag like [""""] to ""
    3 - change any tag like "" to ""
    4 - save and close the file
    5 - reopen the solution and double click on the file, it should work now

    PS : always couble check if the build is set to "Bundle Resource"

  • BehroozTorkiBehroozTorki HUMember ✭✭
    edited March 2018

    1 - open "GoogleService-Info.plist" and change any <true></true> or <false></false> to <true /> and <false />

    2 - reopen the xamarin solution
    3 - it should work now

  • Isha_DawarIsha_Dawar INMember ✭✭


    I have tried you solution still getting the same error!! please help

  • My solution is to open the plist file in Xcode and save it. after that import it again in Visual Studio.

  • marcnegrimarcnegri CHMember ✭✭

    Indeed, it's working. Well done !

Sign In or Register to comment.