Problem with Rg.Plugin.popup plugin

RokiRoki SIMember ✭✭

So i've installed this plgin called rg.plugin.popup, and its needed to define it in mainActivity like this

Rg.Plugins.Popup.Popup.Init(this, bundle);

But the error is : "Severity Code Description Project File Line Suppression State
Error CS0234 The type or namespace name 'Popup' does not exist in the namespace 'Rg.Plugins.Popup' (are you missing an assembly reference?) CloudDMS.DemoMobileApp.Android"

Anyone had a similar problem with this plugin?

Best Answer

Answers

  • AdamMeaneyAdamMeaney USMember ✭✭✭✭✭

    Show either the Android project packages.config or the section of your Android csproj with the package references to make sure you got it installed on the platform correctly.

  • RokiRoki SIMember ✭✭

    I don't have any project.config or Android csproj file. Now when I looked at other project, I had it in. Are those files generated automatically or I need to make them? Sorry, im kinda new to xamarin..

  • AdamMeaneyAdamMeaney USMember ✭✭✭✭✭

    You have to have something in your Android project that details the installed NuGet packages, as otherwise you don't have any installed and that clearly wouldn't go well.

    In your project, you have a CloudDMS.DemoMobileApp.Android.csproj, probably under CloudDMS.DemoMobileApp.Android folder in wherever your project is on your machine.

    At the location that csproj is, there is potential to be a packages.config file, or that csproj file itself.

    One of those files will list any installed packages.

    Otherwise, right click on your Android project in Visual Studio, push Manage NuGet Packages, and add the popup plugin again and you should see it.

    Most likely that is all you need to do either way.

  • RileyASIRileyASI Member ✭✭

    I am working on implementing the rg.plugin.popup into my project and did not add the init code into Droid or IOS solutions and the popups are working properly. In searching I think I found somewhere others were having problems with the init. I downloaded the solution from github and started just to copy only the necessary code to make it work.

  • AdamMeaneyAdamMeaney USMember ✭✭✭✭✭

    I would be interested to read more on problems with the init, because I have it and my app functions fine. Could you by chance point me towards one of the things you were reading?

  • RokiRoki SIMember ✭✭
    edited February 2018

    @AdamMeaney
    @Warwenczack
    I haven't tried using without but in documentation it says that its needed. But since I've installed it a few times i think this namespace just don't have it. Here's the github page: https://github.com/rotorgames/Rg.Plugins.Popup/wiki/Getting-started . This is the github page that I helped with. Have I found the wrong page maybe? Anyway will try witout this init and will tell how it goes

  • WarwenczackWarwenczack BRMember ✭✭

    i think that this is a new version...
    i'm using a old version...

  • AnasBabgiAnasBabgi USMember ✭✭

    have you did solve it ?

  • RokiRoki SIMember ✭✭

    I tried using it without that Init function and it works like @Warwenczack said. The only thing that it doesn't is background click. I have yet to solve that issue, but that isn't so important at the moment.

Sign In or Register to comment.