What causes Visual Studio to fail to launch simulator

I have a xamarin forms project that builds without errors. When I try to run the project from VS the project builds but sometimes (most times) the simulator fails to launch and VS locks up. (stops responding) I have to kill it from Windows Task Manager.
The project is iOS so I am trying to launch on my Mac in the simulator - but I have also tried using the windows simulator.
Visual Studio 2017 - Windows - Version 15.5.5
MacBook Pro -

Not only does the project take a full minute to build but it only launches successfully 1 of 3 times. And when it fails it requires a restart of VS. I'm getting grumpy.

I have tried restarting both machines a number of times.

Any help is appreciated.

Answers

  • ShantimohanElchuriShantimohanElchuri USMember ✭✭✭✭✭

    @MarkJohnston This issue is perpetual. I had this issue many times. Few times resolved by itself on next update and some times I did resolve using many of the methods suggested in this forum. But don't mind if it returns back again.

    Having said that, which year model is your MBP. Mine is 2011 model with the latest Mac OS...and my compilation times are incredibly slow. Many times it takes about 10 mins for the Simulator to show up either on Mac or on Windows. Xcode on Mac always times out if the Simulator is not already up and running.

    Second, Are the versions of Xamarin.iOS on both Windows and Mac match?

    I assume your router /Wifi are fast enough.

  • MarkJohnstonMarkJohnston USMember

    My MBP is 2013 - latest OS - i7 - 16 GB.
    X.iOS versions match
    Network connection is wired and plenty fast.

    I've tried many, if not all, the suggestions I found on this and other forums.
    Tried cleaning before run, rebuild before run etc.
    This really makes Xamarin a miserable developer experience.

    Thanks for your suggestions.

Sign In or Register to comment.