Too early to use netstandard 2.0 on UWP?

marciosouzajuniormarciosouzajunior ✭✭BRMember ✭✭

Hi guys! To use netstandard 2.0 on UWP I need to target fall creators update right? But there is no emulator on VS and just a few smartphones on market that received this update. So what do you recommend for now, to reach the maximum number of users?

Tagged:

Answers

  • marciosouzajuniormarciosouzajunior ✭✭ BRMember ✭✭

    Anybody?

  • AlexPAlexP ✭✭ Member ✭✭
    edited February 2018

    I don't know if you still can do that,
    But AFAIK, you can create a legacy PCL project, which is not based on .Net standard.
    I'm not sure you can actually start a full Xamarin.Forms solution with this type of project,
    But I think you should be able to simply add a new legacy PCL project after you create your .Net standard 2.0 solution, and just swap them up.

    Hope it helps. :smile:

  • marciosouzajuniormarciosouzajunior ✭✭ BRMember ✭✭

    Hi @AlexP! Forgot to say that Im using xamarin.forms nightly build. This build only works with netstandard 2.0.
    The 2.5 relese has some bugs on UWP, so I will come back to netstandard 1.4 and wait for the 2.5.0-sr4 release.

Sign In or Register to comment.