Forum Xamarin.iOS

How to use a MonoMac library on a XamMac application

I'm trying to use a MonoMac dll on a XamMac application. If I try to use the dll, it says I am missing a ref to MonoMac. If I add MonoMac, then it it get ambiguous refs all over the place.

Posts

  • MikeCodesDotNetMikeCodesDotNet GBXamarin Team Xamurai

    Hi,

    I'm sorry to hear you're having issues using Xamarin.Mac.

    I'm a little confused as to why you are using the MonoMac DLL in a Xam.Mac project as you should have a XamMac DLL in your projects references.

    If your project does reference the XamMac.dll then please get in touch with our support team so they can assist you in trying to resolve the issue.

  • I contacted my Xamarin rep and he forwarded it on to the support team but I never got anything back. So I was trying my luck on the forums. It's technically our library but we were hoping that releasing the dll as MonoMac would allow both XamMac and MonoMac users to use it (just that XamMac users it would work better).

  • MikeCodesDotNetMikeCodesDotNet GBXamarin Team Xamurai

    Hi Kraig,

    I've had a look on our system for the support case but wasn't able to find it. Would you mind contacting me through our support channel so I can take a look at whats happened here?

    It would be really useful to get a copy of your project to try and reproduce the issue as I have created a Xamarin.Mac application referencing a library which uses MonoMac and it appears to work without errors.

    Cheers,
    Mike

  • Just send an email to [email protected]?

Sign In or Register to comment.