Brand new project, Android is not running. InflateException

Hi everyone.
I just created a new project on Visual Studio 2015 community. I clicked to run the droid project and I got this message:

Android.Views.InflateException: Binary XML file line #1: Error inflating class android.support.v7.widget.Toolbar

How could it be?
I did not even type a single line of code...

Posts

  • ClintStLaurentClintStLaurent USUniversity ✭✭✭✭✭
    edited December 2016

    @MarceloAmador said:
    I did not even type a single line of code...

    That's probably the issue. The default solutions templates aren't up to date.

    This is such a common problem I touched on it in my tutorial series: Red Pill Xamarin

    Start at the oldest blog entry "Introduction" and work forward. The 100 series of entries is just about getting your environment set up, moving forward into getting the default "Welcome to Xamarin" to even run.

  • MarceloAmadorMarceloAmador USMember ✭✭

    But my UWP project worked fine. I see the message "Welcome to Xamarin Forms!". I can't check the iOS version because I don't have a mac right now. Just the Android version is showing this error.

  • MarceloAmadorMarceloAmador USMember ✭✭

    This is the message:

    And here is the repository:

    https://github.com/marcelojaf/MyTestApp

  • MarceloAmadorMarceloAmador USMember ✭✭

    SOLVED:

    I downgraded Xamarin.Forms NuGet package to version 2.3.107 and worked fine. =) Happy 2017 to everyone.

  • I found redpillxamarin.com from this thread and it is a great blog and tutorial but it's been down the last few days. I sent it to some people on my team and they haven't been able to get into it and are anxious to check it out. Any chance of getting it back online?

    Thanks

  • ClintStLaurentClintStLaurent USUniversity ✭✭✭✭✭

    @KeithMollenkopf said:
    I found redpillxamarin.com from this thread and it is a great blog and tutorial but it's been down the last few days.

    Thanks for letting me know. This is the first I knew. I got side tracked rebuilding and upgrading my 3d printer. Too many hobbies. {laugh}

    I look into it ASAP.

  • Thanks for responding so quickly and thanks for the great tutorial. It's been super helpful getting started in Xamarin!

  • ClintStLaurentClintStLaurent USUniversity ✭✭✭✭✭

    @KeithMollenkopf said:
    Thanks for responding so quickly and thanks for the great tutorial. It's been super helpful getting started in Xamarin!

    Good to know someone is reading it. To be honest with 0 people subscribed to it I have no idea if anyone even reads it. So other things get higher priority for my time. I'll try to carve out more time for it - but please mention to those co-workers that once it is up actually subscribing lets me know its worth my time.

  • ClintStLaurentClintStLaurent USUniversity ✭✭✭✭✭
    edited January 2018

    @KeithMollenkopf said:
    Thanks for responding so quickly and thanks for the great tutorial. It's been super helpful getting started in Xamarin!

    If you get a second can you try it again? It looks like the GeoBlock plugin got confused. I changed nothing but the message someone would receive if they were blocked - and suddenly its happy again and only blocking the countries it should be. Go figure.

    Never mind - its still doing it. And doing it to ME now. Looks like something went sideways at the server about 4 days ago when you say it stopped being visible.

    I wonder if someone banged on it to the point of the plugin closing out EVERYONE except pre-defined IP addresses?
    I might have to try this from home.

  • ClintStLaurentClintStLaurent USUniversity ✭✭✭✭✭

    @KeithMollenkopf said:
    Thanks for responding so quickly and thanks for the great tutorial. It's been super helpful getting started in Xamarin!

    Ok. Give a go now. Let me know if it is still blocking. Thanks!

  • It's working for me now.

Sign In or Register to comment.