Forum Xamarin.Forms
We are excited to announce that the Xamarin Forums are moving to the new Microsoft Q&A experience. Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

We encourage you to head over to Microsoft Q&A for .NET for posting new questions and get involved today.

iOS Icon Madness! Can't submit app

RaymondKellyRaymondKelly USMember ✭✭✭

So I have seen lots of posts regarding issues with icons and app submission to the App Store. None of them seems to resolve my issue. I have tried both the Asset Catalog and info.plist methods and both fail.

  1. Asset Catalog - Gets an error that the 57x57 and 72x72 icon is missing. There are not spots for that in the asset catalog. I tried to hack the project file and catalog to include the files but no luck.
  2. info.plist - This hack allows the app to be submitted, however it gets rejected during processing. The error is: "Missing Asset Catalog - Your app is missing the asset catalog file in ''"

So I cannot figure out how to get this app submitted. I am using Visual Studio 2017 on Windows and using current Stable channel. Any ideas here?



  • AdamMeaneyAdamMeaney USMember ✭✭✭✭✭

    Edit the icons from XCode instead. That should show you the whole list

  • PatMoranPatMoran GBMember ✭✭

    I had similar problems which I could only resolve by using an asset catalog and Visual Studio for the Mac to add the icons.

  • This is broken in Visual Studio 2017 on Windows. I highly recommend only touching the asset catalog with VS for Mac...

  • JohnHardmanJohnHardman GBUniversity admin

    Glad to have found this thread. Was trying to work out how to sort out some icon issues and thinking I had missed something obvious in VS2017. In the end, used a text editor to make required changes (other than editing the icons themselves).

  • RaymondKellyRaymondKelly USMember ✭✭✭
    edited January 2018

    Well I moved everything over to VS for Mac and still no luck. The asset catalog does not have a spot for 57x57. and the same error occurs. @JohnHardman, how did you manually edit? I tried that as well and still did not work.

    @AdamMeaney same goes for xcode, no spot for 57x57.

    I think the difference here is that I am supporting iOS 6 and 57x57 is required for that. ios 7.0 and higher does not need it.

  • JohnHardmanJohnHardman GBUniversity admin

    @RaymondKelly - I haven't submitted the app to the appstore yet, so don't know that I've got it completely right. I originally added the icons for my app when using VS2015, adding all the images in sizes then shown in VS. When I changed to using a storyboard for the launch screen (after migrating to VS2017) I was not getting the expected result on iOS, so wanted to understand what was going on in terms of how a particular icon was ending up on the launch screen - was it being referenced by the storyboard, or was it something left over from the pre-storyboard days.

    I searched all files for "storyboard" and for the names of the icon files. I found all sorts of redundant stuff, so (after checking everything was in version control, and that I had a backup of the folder structure) I went through the files containing matches from the search, editing them to remove what I believed to be redundant stuff, whether deleting complete files or removing references to other files using a text editor. So not the same situation as you I'm afraid.

    For me, this thread was useful as I couldn't work out why I was not able to see the VS page with the different sized images. It sounds like that page is kapput in VS2017.

  • chisigochisigo USMember ✭✭

    In my case, the solution was build the app using visual studio for mac or xamarin studio.
    With visual studio 2017 for windows the error still persists

Sign In or Register to comment.