Android Support Repository Error XBD404

I installed the latest SDK platforms for Android 6 and 7. Upon installing and launching Xamarin studio, I got two error message saying to install the latest version of "Google Repository" and "Android Support Repository". I installed the latest version and the error message for "Google Repository" went away but other didn't.

I tried deleting "Android Support Repository" and re-installing, re-booting and none help.

Is their way to fix this error?

Error Message:

Partial Download Failed for one or more parts
A task was canceled.
Please open the Android SDK Manager and install the latest version of 'Android Support Repository' from the 'Extras' section, and then reload your solution.

Answers

  • mayuemayue USMember ✭✭

    This problem has been bothering me for a long time!!!It has not been solved yet

  • LuanSantiagoLuanSantiago USMember ✭✭

    I'm with the same problem, any solution?

  • TheGreatOneTheGreatOne USMember ✭✭
    edited March 2017

    I found a solution.

    1. Clean solution.
    2. Remove all you GooglePlayService packages and is dependents.
    3. Clean solution.
    4. Close project.
    5. Delete the "packages" folder from you main solution directory.
    6. Open Project.
    7. Install each GooglePlayService package one by one.
    8. Build solution.

    If that doesn't work and if you are using a repository go back to a working commit.

  • LuanSantiagoLuanSantiago USMember ✭✭

    @TheGreatOne said:
    I found a solution.

    1. Clean solution.
    2. Remove all you GooglePlayService packages and is dependents.
    3. Clean solution.
    4. Close project.
    5. Delete the "packages" folder from you main solution directory.
    6. Open Project.
    7. Install each GooglePlayService package one by one.
    8. Build solution.

    If that doesn't work and if you are using a repository go back to a working commit.

    did not work

  • mayuemayue USMember ✭✭

    Can be sure that the nuget package caused by the problem, because I do not have any problems with the new project, but I deleted all the package, the re generation or the problem

  • TheGreatOneTheGreatOne USMember ✭✭

    The problem came back after updating xamarin studio to the latest

  • batmacibatmaci DEMember ✭✭✭✭✭

    what for do we need android support repository? i read that they say it is only for gradle which doesnt exist in xamarin.

  • TheGreatOneTheGreatOne USMember ✭✭

    I don't remember what I did but the issue went away after an update.

  • JonDouglasJonDouglas USXamarin Team, University, Developer Group Leader Xamurai

    Is this still an issue for anyone on this thread? Please let me know.

  • TheGreatOneTheGreatOne USMember ✭✭

    I'm not having this issue anymore.

Sign In or Register to comment.