Forum Xamarin.iOS


The Xamarin Forums have officially moved to the new Microsoft Q&A experience. Microsoft Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

To create new threads and ask questions head over to Microsoft Q&A for .NET and get involved today.

Xamarin.Forms/Xamarin.iOS problem with publishing ipa package to the appstore.


My name is Mark. I'm working for company as a Xamarin developer. After whole proccess of development there is this special moment to finally publish your work in store.

I'm stuck with the following problem for second day in a row.

I'm trying to publish compiled ipa package with Application Loader (delivered with xcode 9.2, ver. 3.7).

I'm getting following errors every time I try to upload.

description length:861761
ERROR ITMS-90680: "The binary you uploaded was invalid."
ERROR ITMS-90085: "No architectures in the binary. Lipo failed to detect any architectures in the bundle executable."

(still cannot posts links, even from implemented image uploader...)

I've tried to compile with many options modified, always same result.

What I've already deduced is:
- I need to setup linker properly, to reduce the size of binary, currently for the development process it was turned off.
- There were some issues reported with app package containing files with filename beginning same as executable name (may that be the case?)
- Verified with lipo it can retrieve correct architectures from main binary

(Forgot to mention I've already read every possible page/topic/post on first 10 pages of google search for above errors)

I'm willing to provide as much info and details as I can, trying to solve this issue for second day in a row non-stop really grinds my gears.

Thanks in advance,


  • JohnHJohnH GBMember ✭✭✭✭✭
    Hi Mark,
    Make sure when you build you select the Release config and you select to build for device. Make sure the architecture is set to Armv7 and Arm64. Are you using VS4Mac?
Sign In or Register to comment.