Forum Xamarin Test Cloud (Read Only)

Xamarin UITest Exception ApkFile or InstalledApp not configured


I tried to run the sample from :

and get that exception:

System.Exception : ApkFile or InstalledApp has not been configured.
bei Xamarin.UITest.Configuration.AndroidAppConfiguration.Verify()
bei Xamarin.UITest.Android.LocalAndroidAppInitializer.VerifyConfiguration()
bei Xamarin.UITest.Android.AndroidApp..ctor(IAndroidAppConfiguration appConfiguration)
bei Xamarin.UITest.Configuration.AndroidAppConfigurator.StartApp(AppDataMode appDataMode)
bei CreditCardValidator.Droid.UITests.Tests.BeforeEachTest() in d:\tmp\CreditCardValidator.Droid\CreditCardValidator.Droid.UITests\Tests.cs:Zeile 19.

WARNING: Tests created using NUnit cannot be uploaded to Test Cloud. The recommended version is 2.6.4.
Full log file: C:\Users\brunneer\AppData\Local\Temp\uitest\log-2016-10-10_02-29-26-454.txt
Skipped IDE integration, connection failed.

Any idea?



Best Answer


  • AnthonyMehallelAnthonyMehallel USMember ✭✭✭

    Hi @EricBrunner ,

    Xamarin.UITest works just with nunit 2.6.3. (and you have installed nunit 3.5.0).

    In the file "packages.config", modified the line :
    and refresh your package in the Reference's file

    Anthony M.

  • EricBrunnerEricBrunner USMember ✭✭

    Hi Anthony,
    Thanks but that was not the only issue I had to solve. The sample from here doesn't work.
    I had to do that:

    • Change to Release Mode and deploy it on a Real Android Device
    • On Emulator I tried to uncheck Shared Runtime but then I couldn't start the App ;-)
    • I had to Configure it like that:

      public class Tests
      AndroidApp app;

      public void BeforeEachTest()
          //app = ConfigureApp.Android.StartApp();
         app = ConfigureApp.Android
      public void CreditCardNumber_TooShort_DisplayErrorMessage()
          // Invoke the REPL so that we can explore the user interface


    So now it is working on a real device in Release Mode. I still struggle with that I running on an Emulator.

  • EricBrunnerEricBrunner USMember ✭✭

    @Arvind.5724 Yeah. I ran it in debug mode.

  • MarekQMarekQ USMember

    EricBrunnter, thank you very much.

    Your solution worked for me.
    Regards MarekQ

  • EricBrunnerEricBrunner USMember ✭✭

    @MarekQ Great !!!

  • FebinDonzManGroveFebinDonzManGrove USMember ✭✭

    Thanks Eric Brunner , its working

  • Ahetejaz1Ahetejaz1 OMMember ✭✭
    edited December 2017

    I am running it in release mode still I am getting below error:

    Potential Android SDK location: C:\Users\Malik\AppData\Local\Android\android-sdk - Valid SDK. [ Source: ANDROID_HOME ]
    Using Android SDK: C:\Users\Malik\AppData\Local\Android\android-sdk
    Using JDK: C:\Program Files\Java\jdk1.8.0_151 [ Source: JAVA_HOME ]
    Attempting IDE connection for Android: D:\MeethaqWallet\MeethaqWallet\bin\Release\MeethaqWallet.DLL.
    No named pipe value found in environment variable XTC_IDE.
    Skipped IDE integration, connection failed.

    Do we need to change something here (in below screen) ?

  • Ahetejaz1Ahetejaz1 OMMember ✭✭

    Screen shot

Sign In or Register to comment.