Forum Xamarin.Android

Android Emulator not displaying in "Select Device" window

I’m having trouble getting Visual Studio to recognize my Android emulator.
Here are the steps I’m following:

  1. Press debug
  2. Start emulator image
  3. Click on available image
  4. Emulator pops up
  5. Select device is blank.

The “Select Device” window does not show my emulator. On occasion, after several tries, it will show up. But it hasn’t been working at all lately. Is there some sort of bug? Or am I missing something here?

Best Answer


  • JonathanPryorJonathanPryor USXamarin Team Xamurai

    In that spirit, there's the IDE does not display target device troubleshooting entry. You may need to restart adb (the adb kill-server and adb start-server commands), and restart your IDE in order to view your target devices.

  • Charles.INCharles.IN INMember

    This happens many times.
    The Emulator does not display the target device.
    I have tried restarting windows several times. It works fine after installation, but suddenly it does not work. I have tried Emulator and also connecting the device, both does not work.

  • Hari-LubovacHari-Lubovac USMember ✭✭
    edited December 2017

    I realize this is old, but it's a problem even today, with VS 2017.

    I didn't know about this MS-provided Android emulator at the time. I experimented with emulators that ship with Android SDK, and I wasn't happy with performance. After I found out about this one, I installed it via a separate download. Installation succeeded, and emulator runs externally. But, no matter what I do, it wouldn't show within the "run" dropdown within VS.

    I spent hours searching and trying various things, until I found this (can't post links): http: //; path: "/2017/03/visual-studio-2017-android-emulation/". The guy mentioned how there is an option to install this emulator as part of VS install/modification, and there it was still unchecked (like, not installed; while it was present on the system). So, after I selected it to be installed there, and completed that VS-modify process, the few emulators (VM's) that I had there (btw, listed are available, not necessarily downloaded/installed) finally showed up! So, I guess, that checkbox also takes care of VS-integration, which isn't covered by the standalone installer (as verified on two different machines, so it can't be accidental).

    Hopefully this helps someone else :)

  • OverheadOverhead USMember ✭✭

    Thanks HariLubovac! Had the same problem, and now working :smile:

Sign In or Register to comment.