Can't build app to deploy on a real device

LGMaestrelliLGMaestrelli BRMember ✭✭✭
edited December 2017 in Xamarin.iOS

Deploying to a simulator running iOS 11.2 it works fine. But when I try to deploy to a real iPad, also running iOS 11.2, i get this build error:

Could not AOT the assembly '/Users/useall-mac/Library/Caches/Xamarin/mtbs/builds/iOS/ec2151b52708c2012ac8b36ec2182fce/obj/iPhone/Debug/mtouch-cache/Build/Microsoft.Net.Http.Headers.dll'

I'm not enabling AOT or LLVM compiler.

I'm using Windows 10.
Visual Studio 2017 15.5.1
Xamarin 4.8.0.753
Xamarin.iOS 11.6.1.2
Xcode 9.2

Any ideas on why this is happening?

Tagged:

Best Answer

Answers

  • UIUXUIUX USMember ✭✭

    @LGMaestrelli said:
    Deploying to a simulator running iOS 11.2 it works fine. But when I try to deploy to a real iPad, also running iOS 11.2, i get this build error:

    Could not AOT the assembly '/Users/useall-mac/Library/Caches/Xamarin/mtbs/builds/iOS/ec2151b52708c2012ac8b36ec2182fce/obj/iPhone/Debug/mtouch-cache/Build/Microsoft.Net.Http.Headers.dll'

    I'm not enabling AOT or LLVM compiler.

    I'm using Windows 10.
    Visual Studio 2017 15.5.1
    Xamarin 4.8.0.753
    Xamarin.iOS 11.6.1.2
    Xcode 9.2

    Any ideas on why this is happening?

    Check This configuration ...keep it uncheck

  • LGMaestrelliLGMaestrelli BRMember ✭✭✭

    Yes, they are unchecked.
    My configuration is the same as yours.

  • LGMaestrelliLGMaestrelli BRMember ✭✭✭

    @kevinsalot
    Yes, it is exactly that.

    Thank you.

Sign In or Register to comment.