Xamain App installed in MobileIron - crash will launching

Created an corporate app and first time trying to install in MobilIron, initially not able to install/download. With some changes in entitlement file by deployment team able to install the app now to the iphone. But not able to launch / open the app, it crashes / terminates while launching. Is there is any way to find out the issue ? or How should we fix this issue ? Please advise.

Posts

  • JGoldbergerJGoldberger USMember, Forum Administrator, Xamarin Team, University Xamurai

    My best suggestion is to view the device console logs when the app crashes. This is often the best place to get an actionable error message.

    Device console logs

    XCode:
    1. Open Xcode with your device attached to your Mac.
    2. Click the Window->Devices menu to open the Devices window.
    3. Select your device from the list on the left and then click the small up arrow button on the lower left of the main pane. This will open the live console logs for the device.
    4. Launch your app and watch the logs.

  • Thanks @JGoldberger. I tried and getting below error in the log.

    : Bootstrapping failed for with error: Error Domain=BKSProcessErrorDomain Code=1 "Unable to bootstrap process with bundleID com.xxx.xxx" UserInfo={BSErrorCodeDescription=bootstrap-failed, NSLocalizedFailureReason=Process already exists for job specification, NSLocalizedDescription=Unable to bootstrap process with bundleID com.xxx.xxx}

  • JGoldbergerJGoldberger USMember, Forum Administrator, Xamarin Team, University Xamurai

    Hmm, never seen that before. Might want to reach out to the MobileIron support. As a first thought, did you join the Apple Enterprise Developer program? You would need to if you are deploying to devices that are not registered in your Apple Developer portal.

  • Thanks @JGoldberger, The device is registered device. but I will reach out to Mobile Iron team also.

Sign In or Register to comment.