Memory/Slowness

Woody712Woody712 ✭✭GBMember ✭✭

Hi,

This is a long shot but could anyone tell me if Xamarin have changed any memory/performance features between May this year and now. I'm sure the answer is yes but the problem I have is releases I built for Android back in May perform fine. Releases I build now (same code, rolled back to same nuget packages from may etc..) perform increasingly slow the more times I go in and out of the same activity (which does a lot of things with strings, memory lists and dynamic control view inflations). So first time it's about a second. 10th time is about 20 seconds! Same code, same data from may is constantly around the 1 second mark.

I've rolled back my SDK manager to approx settings then also. The only thing I haven't changed now is the Xamarin and Xamarin Andoid SDK rollbacks.

This is very worrying, have I missed a setting or something like 'memory work in old way' type setting? Any ideas?

Thanks in advance

Best Answer

  • Woody712Woody712 ✭✭ GB ✭✭
    Accepted Answer

    Reverting back to older Xamin fixed the issues. Fixed in latest version by reworking code to not use SpinnerAdapters. Memory leak somewhere in those.

Answers

  • Woody712Woody712 ✭✭ GBMember ✭✭

    I should say this is Android, not forms.

  • Woody712Woody712 ✭✭ GBMember ✭✭
    Accepted Answer

    Reverting back to older Xamin fixed the issues. Fixed in latest version by reworking code to not use SpinnerAdapters. Memory leak somewhere in those.

  • JonDouglasJonDouglas Xamurai USXamarin Team, University, Developer Group Leader Xamurai

    I would suspect a memory leak. You should profile your application and Help the Garbage Collector

Sign In or Register to comment.