Emulator not building xamarin forms app.

Hi,

My emulator (Nougat 7.1) isn't running. I'm running Visual Studio 2017 on Windows 10. Also, I'm running one of the sample projects, just to check the issue is the emulator not the code. I'm getting this output in the console.

3>Emulator Android_Accelerated_Nougat cannot be started (adb cannot initialize device).
========== Build: 2 succeeded, 0 failed, 0 up-to-date, 0 skipped ==========
========== Deploy: 0 succeeded, 1 failed, 0 skipped ==========

Can anybody help?

Alex

Answers

  • TheodorusGumilangTheodorusGumilang USMember ✭✭
    edited November 2017

    do you enabled your hyper-V ? or maybe you just installing docker for windows ? one time after i'm installing docker for windows my android emulator suddenly wont started and after i check in the android emulator manager i need to disabled the hyper-v features in windows setting. And second case is you not enabled your Hyper-v in bios, you need enabled hyper-v in bios to able start the emulator. and your processor is should be intel

  • SolubleSnakeSolubleSnake GBMember ✭✭

    Hi. I have disabled Hyper-V in windows settings, and when I try to enable it in BIOS, the 'UEFI Firmware Settings' don't appear in the advanced options.

    However, I can run an oraclebox VMWare virtual machine running Debian, so I think Hyper-V must be enabled in the BIOS?

    Really confused.

  • @SolubleSnake go to your AVD Manager and start it from there, and if it cannot started it will show the error message. and let me know is the error message

  • SolubleSnakeSolubleSnake GBMember ✭✭

    Hi,

    I opened the AVD manager and attempted to start the emulator. What I then got told me my emulator was out of date. I went into the SDK manager to update the emulator and it won't update because it says that folder is in use (google_API\x86).

    I disabled my virus software and it still says the folder is in use....

    I have an actual device now, so may just use that for testing....although it's very slow!

  • @SolubleSnake you can try make new emulator in emulator manager with the newest android, and try to update your sdk manager again

Sign In or Register to comment.