Connection Error - VS Emulator with Hyper-V

felipedrtfelipedrt USMember ✭✭

Hi, good morning!

I'm not getting connection on my VS Emulator, someone could help me? I am using VS Emulator for Android.

I need to configure something on Hyper-V? My error happened when I try to connect in some WebService, because of this I think that is device connection problem.

Here is my C# code:

public static async Task<List<Model.Livros>> GetAsync()
{
using (var client = new HttpClient())
{
var json = await client.GetStringAsync("http://mvalivros.azurewebsites.net/api/livros");
var livros = JsonConvert.DeserializeObject<List<Model.Livros>>(json);
return livros;
}
}

Device error:

Hyper-V config:

Thanks guys, waiting for answers.

Cheers!

Best Answers

Answers

  • Luis_dmLuis_dm USMember ✭✭✭

    Look at network of connections, where are the wifi networks, might not have permission to use the Internet.

  • felipedrtfelipedrt USMember ✭✭

    @LuisRodriguez92 I have this network connections here:

    I need to share some connection? And on Hyper-V, I need to enable, or disable some adapters (Internal/External) ?

    Cheers!

  • DotNetDev1DotNetDev1 USMember

    @felipedrt Tried this, but I still can't connect to the internet from my Android emulators when using WiFi on my host computer to connect to the internet. Host is a Macbook pro and development environment is visual studio 2015 running on a Windows 10 VM using parallels. When I connect an ethernet cable to the Macbook the emulator is able to connect out to the internet, but when using WiFi it won't connect. Has anyone else had this issue?

    Thx.

    @felipedrt said:
    Guys, I find the solution!

    I manually configure my WiFi Connection on device, and it works.

    If somebody has the same problem, follow the steps:

    Settings -> Wi-Fi -> Hold the click on Wired eth1 -> Modify Network
    1. Change the IP Settings to STATIC
    2. Set the ip address with local machine ip adding number 1 at the end
    3. Set the gateway, with local machine gateway
    4. If DNS 1 not filled, set it to 8.8.8.8
    5. If DNS 2 not filled, set it to 8.8.4.4

    Follow the images:

    1. Config:

    2. Internet access:

    Really appreciate the help guys, thanks!

  • millos21millos21 USMember
  • ArinXamaArinXama INMember

    Unable to change Wired eth2 setting

Sign In or Register to comment.