Packages folder missing

BenjaminTooleBenjaminToole USMember ✭✭✭

Just created a new Forms solution. When it loads the packages folder for the shared project is missing. Is this normal?

Answers

  • SachaSchwabSachaSchwab USMember
    edited November 2017

    I get the same issue too. It seems that packages are installed, but can't add new ones. Only on iOS and Droid level but that does not help. I tried to install an new .NET Core project and shift the files there, but the despite re-shifting the references from iOS and Droid, file paths seem to be an issue. So it would be cool to find out how to add packages in the base version from Benjamin above. Any help?

    Right after the above comment I found out that actually the packages have to be installed under iOS and Droid level. It all works fine.

    Thanks also to ThomasKlejna

  • seanydaseanyda GBMember ✭✭✭✭✭

    Try updating your Visual Studio to a more up-to-date build, or downgrade if you're on the latest. I've never came across that before.

  • TomasKlejnaTomasKlejna USMember
    edited November 2017

    Shared project doesn't have packages, only PCL or .NET Standard project do. References for shared project are in platform projects (ios/droid/uwp...)

  • vesterdekvesterdek USUniversity
    edited January 26

    I thought that PCL is the preferred and recommended way of doing things, it's really odd that the default "Forms App" template produces Shared Library behind the scenes, with no option to choose otherwise. I'm using VisualStudio 2017 for macOS

Sign In or Register to comment.