Could not find android.jar for API level 26

JakeAnsteyJakeAnstey USMember ✭✭

So in the past few days, I have been getting loads of errors after updating my xamarin.forms nuget package.

My application is looking for API level 26 when I am not targeting that version, but I actually do have it installed.

Full message:

Severity Code Description Project File Line Suppression State
Error Could not find android.jar for API Level 26. This means the Android SDK platform for API Level 26 is not installed. Either install it in the Android SDK Manager (Tools > Open Android SDK Manager...), or change your Xamarin.Android project to target an API version that is installed. (C:\Program Files (x86)\Android\android-sdk\platforms\android-O\android.jar missing.) Project.Android

I've checked, and sure enough I don't have android-O folder in my API platforms folder.

What I've tried so far:

Updated to the preview channel for Android level 26,
Copying my android-25 folder and renaming to android-O which throws an error about Android.Views.View.set_focusable not found.

Any help appreciated!

Best Answer

Answers

  • LjusnanLjusnan DEMember ✭✭✭

    Hi, Xamarin does not support API 26 yet, so I think you have to use API 25 instead.

  • BhaurajBiradar.9064BhaurajBiradar.9064 USMember ✭✭

    Hi @Ljusnan - API 25 is also not supportable. I received an error

    error : Could not find android.jar for API Level 25. This means the Android SDK platform for API Level 25 is not installed. Either install it in the Android SDK Manager (Tools > Open Android SDK Manager...), or change your Xamarin.Android project to target an API version that is installed. (C:\Program Files (x86)\Android\android-sdk\platforms\android-25\android.jar missing.)

  • divagarkdivagark USMember

    could not find android.jar for Apl level26 .This means the Android Sdk platform for Api level 26 is not installed

  • JakeAnsteyJakeAnstey USMember ✭✭

    Just for reference, I removed all Nuget packages from all projects and re-installed Xamarin Forms package which came with all correct dependency packages.

Sign In or Register to comment.