Forum Xamarin.iOS

Native linking failed - MT5211 - Objective-C - on Mac

I'm new to Xamarin.iOS on Mac and I keep getting the same error regardless of what I've altered in accordance with the information I've read regarding the error code. The project is a test project (xUnit.NET 2 testing framework)

I'm using Xamarin, latest version (7.2.2 (build 7)) and have created a Link Library for Objective-C code from Xcode (9.0.1).
The error is as follows

"MTOUCH : error MT5211: Native linking failed, undefined Objective-C class: *. The symbol 'OBJC_CLASS$_*' could not be found in any of the libraries or frameworks linked with your application."

The information regarding MT5211 point to [Protocol] being missing from the interface declaration, but it isn't. I've tried to re-bundle the *.a file but without success.

There are some issues I've stumbled on, for instance, I cannot build the Xcode project higher than 10.3, since the armv7 does not support iOS11

"error: invalid iOS deployment version '-miphoneos-version-min=11.0', iOS 10 is the maximum deployment target for 32-bit targets [-Winvalid-ios-deployment-target]"

Could that have an effect on the issue?

We have linked libraries in older versions of Xamarin, with success, so is this something that has happened with newer version of Xamarin or of the iOS system?

Please let me know if you might have solved similar issues or know of any solutions.


  • An update on this issue:

    I re-bundled the app in version 9.1 and altered the definition file successfully at the end. It was like the changes I made before weren't picked up by the build, but finally did in the end.

Sign In or Register to comment.