Forum Visual Studio
We are excited to announce that the Xamarin Forums are moving to the new Microsoft Q&A experience. Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

We encourage you to head over to Microsoft Q&A for .NET for posting new questions and get involved today.

Visual Studio Version for Mac 7.2 build 636 Breaks Connection with XCode

I just updated Visual Studio for Mac (10/19/2017) and now it is impossible to open any of my Mac Project .xib files with Interface Builder. All was working perfectly with the previous version but now I only get the following error:

Error updating Xcode project

That is the only information given. If I use Xamarin Studio, everything works perfectly. Also, I can open the .xib files directly with XCode, so XCode Interface Builder is not having the problem.

In addition, if I open an IOS project, I can successfully open any .xib file with Interface Builder. It appears the problem only manifests itself with Xamarin Mac projects.

I hope someone can help.

Here is my current environment:

Visual Studio Community 2017 for Mac
Version 7.2 (build 636)
Installation UUID: 1fc6bfac-a399-4041-b142-c40c053d5655
Mono (2017-06/71277e78f6e) (64-bit)
GTK+ 2.24.23 (Raleigh theme)

Package version: 504000201


.NET Core
Runtime: Not installed
SDK: Not installed
MSBuild SDKs: /Library/Frameworks/Mono.framework/Versions/5.4.0/lib/mono/msbuild/15.0/bin/Sdks

Version: 1.5.6
Location: /Applications/Xamarin Profiler

Apple Developer Tools
Xcode 9.0 (13247)
Build 9A235

Version: (Visual Studio Community)
Android SDK: /Users/robertdaly/Library/Developer/Xamarin/android-sdk-macosx
Supported Android versions:
4.0.3 (API level 15)
4.4 (API level 19)
6.0 (API level 23)

SDK Tools Version: 24.4.1
SDK Platform Tools Version: 23.0.1
SDK Build Tools Version: 23.0.1

Java SDK: /usr
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

Android Designer EPL code available here:

Version: (Visual Studio Community)
Hash: 2f8bbec0
Branch: d15-4-xi
Build date: 2017-10-05 20:56:05-0400

Version: (Visual Studio Community)

Xamarin Inspector
Version: 1.3.2
Hash: 461f09a
Branch: 1.3-release
Build date: Tue, 03 Oct 2017 18:26:57 GMT
Client compatibility: 1

Build Information
Release ID: 702000636
Git revision: b349c8fc0c2e1aab0179917d56eed75eb3a03337
Build date: 2017-10-06 15:20:04-04
Xamarin addins: a8da992c78f7eb65b3cdb3f951c34a30337cab35
Build lane: monodevelop-lion-d15-4

Operating System
Mac OS X 10.12.6
Darwin 16.7.0 Darwin Kernel Version 16.7.0
Thu Jun 15 17:36:27 PDT 2017
root:xnu-3789.70.16~2/RELEASE_X86_64 x86_64


  • RobertDalyRobertDaly USMember ✭✭

    As a last resort, I created a brand new .xib with associated .cs file and that too, won't open in XCode Interface Builder.

  • RobertDalyRobertDaly USMember ✭✭
    I tested on another computer running the same versions and the same issue persists. Another test was to create an ‘Hello Mac’ which worked since there was no .xib file, it used story boards which did open properly in XCode.
  • JGoldbergerJGoldberger USMember, Forum Administrator, Xamarin Team, University Xamurai


    Whenever you open a storyboard or XIB file in XCode Interface Builder from Visual Studio for Mac (or Xamarin Studio in the past) an actual XCode project gets created in the obj folder of the project. You will see an Xcode subfolder of the obj folder which you can safely delete. You can also safely delete the entire obj folder as it will get regenerated on the next build. So the first thing I would try is cleaning your solution and even deleting the obj and bin folders of your Xam.Mac project to absolutely insure a full clean.

  • RobertDalyRobertDaly USMember ✭✭

    Hi Jon, Thanks for the information, however, I did as you mentioned and the error still persists. Also, there is no Xcode subfolder in the obj folder. Willing to try anything, if you have any more suggestions.

  • Oleg_DemchenkoOleg_Demchenko RUMember ✭✭


    For us to investigate this further, could you please provide IDE logs (Help -> Open Logs Directory in Visual Studio Mac). Also if you can create a short sample app that would be very helpful.

    I tried to reproduce the bug with new Xamarin.Mac project and one of our public samples:

    but no luck. Perhaps, the bug is specific to the *.xib file in your project.

  • RobertDalyRobertDaly USMember ✭✭

    Hi Oleg,

    I can send you a log file, but the last one is from 5 days ago. When I get the error and then look at the log file directory, there is nothing that has been modified! Is there a special one I need to look for? Also, I tried your sample and it did work. I then created a testViewController, which created the standard testViewController.cs, …designer.cs and .xib file. That one also exhibits the problem. But if I create the same thing in a new solution, it opens fine, therefore I don’t think its the .xib file, but I can send you both .xib files. I can also send you the entire application code. Just as background, I built this from an older version of Xamarin from years ago. Please let me know if this is what you need me to do.

    Thanks again for your help.


Sign In or Register to comment.