Forum Xamarin.iOS

Tools -> iOS options disabled

dpedrinhadpedrinha DEMember ✭✭✭

I installed Visual Studio for Windows with the Xamarin option enabled on the setup but when I run it, the Tools -> iOS options are disabled.

I can see it as disabled and can't click on it.

Any ideas?

Tagged:

Best Answers

Answers

  • GeraldVersluisGeraldVersluis NLUniversity ✭✭✭✭

    Could you please check if Xamarin.iOS is installed (correctly)?

    Go to Visual Studio, click Help > About Microsoft Visual Studio and check under Installed Products if Xamarin.iOS is listed there.

  • dpedrinhadpedrinha DEMember ✭✭✭

    Yes it is.

  • rmaciasrmacias USBeta, University ✭✭✭✭✭

    Are you connected to a Mac from Visual Studio? You still need to have a Mac to act as your build host.

  • dpedrinhadpedrinha DEMember ✭✭✭

    @rmacias said:
    Are you connected to a Mac from Visual Studio? You still need to have a Mac to act as your build host.

    That's the problem, the options are disabled so I can't connect.

  • dpedrinhadpedrinha DEMember ✭✭✭

    No, I don't have any project. I installed it for the first time, following the tutorial and the first step there is to connect to a mac and then create the first project.

  • dpedrinhadpedrinha DEMember ✭✭✭

    https://developer.xamarin.com/videos/
    Installing Xamarin on Windows option.
    And there's no project on the Solutions explorer on the video when he connects to the mac.

    Anyway, I tried creating a new project like on the tutorial and I got one more problem for my collection: "A problem was encountered creating the subproject 'test.Droid'. Value can not be null. Parameter name: path1. GREAT! Probably because of my other question here on the forum about "Why can't I install Android SDK setup".

    But besides that error, with an iOS project on the Solution explorer, the iOS options are enabled. Thanks!!

    I'm actually having a hard time starting with Xamarin since all videos and tutorials seems to be outdated. All the videos show even completely different install interfaces. It doesn't even looks like a Windows solution, looks like a Linux-full-of-dependencies-not-for-noobs software. And I'm used just to Android. So easy, install-and-go and it's JAVA!

    Also it says "develop for iOS, Android and Windows" but when one get to the tutorials there're only iOS and Android ones.
    Any tip where to start with the latest version? I could use an updated tutorial on how to install this thing because it's not working.

    Thanks

  • pokerpuppokerpup USMember
    edited April 2016

    ... Didnt read the above update!

  • microvbmicrovb CAMember

    I am seeing the same issue. The video does look current, as it reflects use of Xamarin as part of the new offering built into Visual Studio 2015, and the Xamarin dev in the video does not have a project open. In fact, if you look at when he does do a Universal project, he connects to iOS using the Mac Agent before creating the new Universal project (which makes more sense).

    Proof of Install

    Depiction of Failure

    The install tutorial from Xamarin depicting how to connect Installing Xamarin on Windows.

    • The first project created is at 9:35
    • Mac is connected prior to this starting at 8:05 until 9:14 (No project open)
    • Mac is first connected starting at 5:46 until 7:14 (No project open)

    Please correct the distribution copy of Xamarin so that it matches the one in the video where iOS is able to be connected prior to starting a project. In addition, it would be super cool if we could save the credentials for the Mac OSX box, and if you made it clear that SSH is not all you need on your mac, that developers need the full blown Xamarin Studio installed on the Mac as well as current Xcode + MacOSX, which installs Java, and all the Android runtime stuff as well even though no Android development is being done on the Mac. (It would be nice if the Mac version and windows version gave the user the option to develop for Android or not on that machine so that those runtimes are not installed. Having Java installed for Android development on my Mac build box which I intend to use only for iOS building from my PC

  • I know that it has been some time since this was posted, but I think that you are meant to connect to the remote Mac first in the tools\options\xamarin\ios section first.

Sign In or Register to comment.