Forum Xamarin.Android
We are excited to announce that the Xamarin Forums are moving to the new Microsoft Q&A experience. Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

We encourage you to head over to Microsoft Q&A for .NET for posting new questions and get involved today.

Xamarin UI Test unable to find the local device

Initialization method GeneralTest.Initialize threw exception. System.Exception: System.Exception: No devices connected..
bei Xamarin.UITest.Android.LocalAndroidAppInitializer.GetDeviceSerial(IAndroidAppConfiguration appConfiguration)
bei Xamarin.UITest.Android.LocalAndroidAppInitializer.PrepareEnvironment()
bei Xamarin.UITest.Android.AndroidApp..ctor(IAndroidAppConfiguration appConfiguration, IExecutor executor)
bei Xamarin.UITest.Configuration.AndroidAppConfigurator.StartApp(AppDataMode appDataMode)
bei TestUtils.BaseUnitTest.Initialize() in ____\dotnet\Xamarin\Android\Shared\TestUtils\BaseUnitTest.cs:Zeile 37.

adb sees the device.
I can start my app on it any time.

Just the Xamarin UI Test refuses to launch.

Xamarin UI Test 2.1.4
Platform tools 26.0.1

adb kill-server - tried
Restarted the PC - tried
Restarted the phone - tried

Tagged:

Best Answer

  • StanislavTsukrovStanislavTsukrov DEMember ✭✭
    Accepted Answer

    Solved.
    Xamarin UI Test tried to communicate to a dated adb version from an orphan Android SDK.

Answers

  • StanislavTsukrovStanislavTsukrov DEMember ✭✭
    Accepted Answer

    Solved.
    Xamarin UI Test tried to communicate to a dated adb version from an orphan Android SDK.

Sign In or Register to comment.