Forum Xamarin Xamarin.iOS

Application Loader Errors - iOS Icons missing Resources and Asset Catalogs

RCWadeRCWade USMember ✭✭
edited June 2016 in Xamarin.iOS

Updated Info: Forgot to add, that I am using VS2015 Community, and the project is Xamarin.Forms

So I am having troubles getting the my app uploaded to iTunes connect.

I have taken a few approaches to resolve this issue, but none have worked. It seems each time I make a move, I get a different error, or the same errors pop up at different times.

Initially, I got an error claiming my ipa file did not have an icon 167x167. I tried to add the icon to my resources, and named it [email protected] This approach still gave me the same error regarding the missing icon.

After some research, I took the suggestions to migrate my images to an Asset Catalog. I created the catalogs for AppIcons and LaunchImages, and populated all of the images presented to me in those new catalogs.

After a clean and build, I uploaded the IPA file again, and this time I got a message that my package was missing 3 icons. 76x76, 152x152, and 120x120
I am getting error messages ITMS-90022 and 90023

My asset catalog has these sizes in it.

Snip from Contents.json with extra items not listed in the error removed.:
"scale": "2x",
"size": "60x60",
"idiom": "iphone",
"filename": "csp_120x120.png"

  "scale": "1x",
  "size": "76x76",
  "idiom": "ipad",
  "filename": "csp_76x76.png"
  "scale": "2x",
  "size": "76x76",
  "idiom": "ipad",
  "filename": "csp_152x152.png"

Also, I have double and triple checked that each file is the correct size and format, etc.


  • SebastianSeidel.9226SebastianSeidel.9226 DEInsider, University ✭✭✭✭

    If you double click on your Images.xcassets and select AppIcons on the left you should see what icons are missing. So depending on what device type you targeting make sure to add all the required icons.

  • RCWadeRCWade USMember ✭✭
    edited June 2016

    There are no icons missing in my AppIcon or LaunchImage catalog and the specific icons which are listed in the errors are shown above in the snip of text from the Contents.json file within the AppIcons.appiconset folder.

    Just as a test, I deleted my catalog and created one labeled 'Images' rather than the default name of 'Media' which VS creates. I re-added all of my icon images, verifying the sizes again.

    Upon uploading again, I now get an additional error for the 167x167 icon, which exists in my catalog same as the 120x120, 76x76, and 152x152..

  • ZachGreenZachGreen USUniversity

    Did you ever figure this out? I am having the exact same issue. I haven't changed any icons from the last time I submitted to the app store, but now I am getting both of the errors that you were.

  • RCWadeRCWade USMember ✭✭

    I never did get the problem resolved, instead I am using the older method of adding my icons to the Resources folder and manually correcting Info.plist to add back in the 167 icon.

    the only trick is that I NEVER open Info.plist in Visual Studio, as it will break the 167 size icon, so I use NotePad++, and manually change my build numbers when needed to prevent VS from breaking the icon list again.

  • ZachGreenZachGreen USUniversity

    The comment about VS breaking the file seems familiar. I know I have submitted to the app store since these icons were required. Maybe that had something to do with how I fixed it last time.

    Thanks for the reply.

  • ZachGreenZachGreen USUniversity

    Ended up needing to manually add those files in particular to the plist file. I didn't have any problems with Visual Studio editing the file. The rest of the files are in the Icon Asset Catalog


    [email protected]
    [email protected]
    [email protected]

  • RaymondKellyRaymondKelly USMember ✭✭✭

    Same issue here, still broken on latest everything. Going to revert to info.plist.

  • StuartCampbellStuartCampbell USMember

    Me too - broken, complains about random icons each time - all of which exist in the folder and contents.json file

  • Same problem - did anyone ever figure this out? It's been over a year since this was reported. Even tho I've regenerated everything using Xamarin Studio (which I hate), it still can't find the files, even tho they exist.

  • ciani.afonsociani.afonso USUniversity ✭✭

    Same problem here, but fixed creating again by myself the complete assets and added one by one all the icons needed.

  • Gigex42Gigex42 USMember ✭✭✭✭
    edited October 2017

    @ciani.afonso what exactly did you do?

    Wanted to push an update for my existing app but nope..
    After I created my Asset catalog it still gives me errors:

    Your binary is not optimized for iPhone 5 ....

    and also:

    Invalid Image Path - No image found at the path referenced under key 'CFBundleIconFiles'


    Just removed the complete 'CFBundleIconFiles' part from my info.plist.

    Now im getting a little less errors.
    Still remaining the iPhone 5 binary error and its missing an icon with 57x57 pixels which isnt even asked for in the catalog..

    And Another Edit:
    Added now the icons 57x57 and 72x72 separatly into my project + plist and im getting no error at this side.

    Still left the iPhone 5 error.

  • ciani.afonsociani.afonso USUniversity ✭✭
    edited October 2017

    I deleted all the assets, then I recreated an asset and I added again all the icons, but one by one.

    To solve the problem of CFBundleIconFiles you have to add this key into the info.plist and his value is the name of your asset, in my case, AppIcon


  • Gigex42Gigex42 USMember ✭✭✭✭

    Got it finally working..

    First deleted all my assets within my project. Added then the images in the asset catalog.

    Now when uploading the ipa file from the application loader I got still some errors left (Missing images).
    Those images in put manually in my project and added them in the info.plist..

Sign In or Register to comment.