Forum Xamarin.Forms
We are excited to announce that the Xamarin Forums are moving to the new Microsoft Q&A experience. Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

We encourage you to head over to Microsoft Q&A for .NET for posting new questions and get involved today.

Xamarin UI test, NUnit version unspported?

SpaceMonkeySpaceMonkey GBMember ✭✭✭

When I try to run a test I get the following internal error:

enter image description here

I have the following packages installed:

    <packages>
      <package id="Microsoft.Bcl" version="1.1.10" targetFramework="net45" />
      <package id="Microsoft.Bcl.Async" version="1.0.168" targetFramework="net45" />
      <package id="Microsoft.Bcl.Build" version="1.0.21" targetFramework="net45" />
      <package id="Microsoft.Net.Http" version="2.2.29" targetFramework="net45" />
      <package id="NUnit" version="3.0.0" targetFramework="net45" />
      <package id="Xamarin.UITest" version="1.2.0" targetFramework="net45" />
    </packages>
Tagged:

Answers

  • SpaceMonkeySpaceMonkey GBMember ✭✭✭
    edited December 2015

    Answer:
    Need to downgrade to NUnit 2.x to be able to run within the IDE

  • OctagonOctagon USMember ✭✭

    It's 2017 and NUnit is on 3.8.x. Does it remain true that Xamarin.UITest requires NUnit 2.6.x?

Sign In or Register to comment.