No IntelliSense anymore

MD5590MD5590 USMember ✭✭
edited September 2017 in Xamarin.Forms

Hi there,
i have a Xamarin Forms Project with a Shared Project, iOS and Android. Also two PCL's are included.
Since last Week I do not have any IntelliSense working in *.cs and *.xaml files, except the PCL's.
When i create new Projects, or open others everything works fine!

I get this Errors(Each of them for iOS and Android Project):
Warning IDE0006 Error encountered while loading the project. Some project features, such as full solution analysis for the failed project and projects that depend on it, have been disabled. .Xamarin.Android 1 Active

Warning The specified path, file name, or both are too long. The fully qualified file name must be less than 260 characters, and the directory name must be less than 248 characters. .Xamarin.iOS Xamarin\App.xaml

I have already googled a lot and found a lot of solutions, but non of them worked. I do not know what to do.
Because this Project is on a TFS other Developers can also open it. They do not have any problems. I already reinstalled the whole VS2017...
Enabling and disabling Resharper does not have any effect.

Any ideas?
Thanks in advance!

Best Answer

  • MD5590MD5590 US ✭✭
    Accepted Answer

    Ok, finally i got it working again.
    What i did:

    • Change th Project folder to a shorter path. (After this nothing changed)
    • Removed all References and NuGet-Packages from Android and iOS Projects
    • Added them again
      => IntelliSense is back! :)

    Hope this also helps others.

Answers

  • Dmitriy_ShDmitriy_Sh UAMember

    Windows has a dumb limitation, where it will refuse to work with any path if folder part of it is 248 characters or longer, or the whole path is 260 symbols or longer. You could try to edit your group policies to enable NTFS long paths, or move your project folder closer to the drive root.

  • MD5590MD5590 USMember ✭✭

    Thanks for your answer.
    I have already enabled NTFS long paths. I also tried to set the output folder of the project to a closer to root folder. Nothing changed...

  • MD5590MD5590 USMember ✭✭
    Accepted Answer

    Ok, finally i got it working again.
    What i did:

    • Change th Project folder to a shorter path. (After this nothing changed)
    • Removed all References and NuGet-Packages from Android and iOS Projects
    • Added them again
      => IntelliSense is back! :)

    Hope this also helps others.

Sign In or Register to comment.