Forum Visual Studio
We are excited to announce that the Xamarin Forums are moving to the new Microsoft Q&A experience. Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

We encourage you to head over to Microsoft Q&A for .NET for posting new questions and get involved today.

Xamarin can't find NavigationPageRenderer class

I recently installed Xamarin and I was doing the tutorials and all was fine building and deploying the project to the Visual Studio Android Simulator. Suddenly I started doing the tutorial for multiple contentPages (multiple views). When I deploy my project to the simulator , Xamarin prompts me with a window that says "Find Source: NavigationPageRenderer.cs" and since i didn't knew where it was I just cancelled it and now my project doesn't deploy but it does build correctly.

I've tried making a completely new Xamarin.Forms Portable project and it doesn't work anymore. I've also reinstalled Xamarin and the prompt just appears again. Please help me this is getting really annoying.

Best Answer


  • LLapresiLLapresi USMember
    edited September 2016

    Bumping this. I've been having the same issue from several installs of Xamarin, one via the Universal Installer and another through the manual method.

    Clicking cancel on the file opening prompt gives an "Unhandled Exception: System.MissingMethodException: Method 'Android.Support.V4.Widget.DrawerLayout.AddDrawerListener' not found."

    (Developing for Android via. VS2015 on Windows 10 Anniversary x64)

  • Thanks a lot good sir :smile: you really helped me

  • dd2dd2 USMember

    I spent over 12 hours (downloading, uninstalling, reinstalling visual studio , xamarin etc.) trying to get Droid project to run via VS2015 on windows 10 and ran into the exact same problem. Thank you very much Luke for your answer as this was the only way I could get this working. I was very excited about xamarin for cross-platform mobile app development, I am currently at ignite and am very new to xamarin and have been going to the sessions. I was getting a bit discouraged that it took so much just to get the default project to run using the droid visual studio emulator. Thanks again for your suggestion, because following on with the tutorials using the universal installer or the visual studio installer does not work.

  • RodrigoSantamariaRodrigoSantamaria USMember
    edited October 2016

    I spent four days of my life in this problem. Thank a lot

  • DanMeierDanMeier USMember

    Did you ever resolve the Unhandled Exception error? I've got the same error - even after reinstalling Xamarin.

    I, too, am new to Xamarin development, and just working to get a default project with no code to run in UWP, Android and iOS. This seems like the most modest expectation possible, and yet I've been fighting the environment unsuccessfully for over a week now, and have all sorts of crazy errors. Finally got the UWP app to run in the emulator, but haven't been successful so far with the Android or iOS.

    iOS turned into a nightmare "provisioning" things on the macOS side, but I think I've finally gotten past that. The basic app runs in the new VS-based iOS emulator, though control sizing and positioning is all wrong. However, still having provisioning problem trying to run the app through my Mac build box on an actual iPhone for testing.

    I love the potential that Xamarin offers, but WOW! What a brittle environment! Not sure I can afford to spend much more time on this with so little progress.

  • Herb.1400Herb.1400 USMember

    if your pc x64, download and install java jdk x64, add in visual studio extras > options> xamarin options >jdk x64 path

  • JamesMontemagnoJamesMontemagno USForum Administrator, Xamarin Team, Developer Group Leader Xamurai

    So I just reproduced your issue and I am sorry that you and other ran into this. It looks like there was an issue in the templates and I am working with the team to quickly resolve this.

    To fix:

    • Simply right click on the android project and select "Manage Nuget Packages"
    • Go to Updates
    • Find Xamarin.Android.Support.v7.AppCompat
    • Select version 23.3.0 from the version picker and hit Install
    • You additionally will need to install the RecyclerView 23.3.0 NuGet Package. Go to Browse and search for: * Xamarin.Android.Support.v7.RecyclerView and make sure to pick 23.3.0 to install for the correct version
      Now do a full clean/rebuild and it should work

    • This should install the correct versions of everything you need for Android

    Additionally, you can just update Xamarin.Forms to the latest package and it will update all the dependencies needed

  • @JamesMontemagno Thanks for your answer. This help me a lot. I don't understand why VS2015 check this and make this updates automatic?

  • @JamesMontemagno Brilliant. Thank you, you're instructions worked for me too and I'd be lost without them!

  • SkrillexSkrillex USMember

    James's steps worked for me, thanks for the post. I unfortunately had to restart VS between every step but it got me through!

Sign In or Register to comment.