The Xamarin Build Agent is not running on the Mac.

HashirFaizyHashirFaizy USMember ✭✭

The Xamarin Build Agent is not running on the Mac. An active Build Agent is required to perform the build.

Answers

  • Sam_zeusSam_zeus PKMember

    This guide gives investigating ventures to issues that might be experienced utilizing the new association administrator, including network and SSH issues.

    (https://developer.xamarin.com/guides/ios/getting_started/installation/windows/connecting-to-mac/troubleshooting/)

    For more information, you can visit us on

    https://iosappers.com/news/

  • AnasDilshadAnasDilshad USMember

    @Sam_zeus said:
    This guide gives investigating ventures to issues that might be experienced utilizing the new association administrator, including network and SSH issues.

    (https://developer.xamarin.com/guides/ios/getting_started/installation/windows/connecting-to-mac/troubleshooting/)

    For more information, you can visit us on

    https://iosappers.com/news/

    Authentic .. (y)

  • HashirFaizyHashirFaizy USMember ✭✭

    thanks , guys i fixed it by uninstalling and installing Xamarin back again in Visual studio.

  • BriochebroBriochebro CAMember ✭✭

    That didn't work for me. I have one PC running the emulator fine and one PC with the exact same installed components which is not working. I removed Xamarin from that PC, and then reinstalled it.

    My Visual Studio is connected successfully with the mac (I see the little green monitor in the VS toolbar), but as soon as I try to run my app, I get the error :

    "The Xamarin Agent is not running on the Mac. An active Build Agent is required to perform the build."

    I don't know what to do anymore.

  • rseostarrseostar USUniversity ✭✭

    I'm getting the same thing, a bug has already been submitted by someone else. I'm off to try re-installing as that usually fixes weirdness like this.

  • BriochebroBriochebro CAMember ✭✭

    Turns out VS updated my Xamarin.IOS sdk to a preview version. I went into Extensions and Updates, selected Xamarin.iOS SDK and hit 'Revert'.

  • TrevorHeinsTrevorHeins USMember ✭✭

    @Briochebro said:
    Turns out VS updated my Xamarin.IOS sdk to a preview version. I went into Extensions and Updates, selected Xamarin.iOS SDK and hit 'Revert'.

    Thank you so much! Struggled with figuring out why all day yesterday...thought it had to do with the Mac side...ugh

  • GillesDignardGillesDignard CAMember ✭✭

    Thanks. Not being able to build was not fun. Reverting didn't work, but using the VS Installer to uninstall then reinstall Xamarin did. Building again, so they've taken me off the heart monitor.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai
    edited August 2017

    Bugzilla cross-reference

    This appears to be an issue with some unexpected extension update information being provided by the Xamarin Updater extension that it reads from online. I've notified the team, and an adjustment is now in place for the online information that should in theory stop this issue from affecting any more users who are updating.


    EDIT Aug 23: Add a clarification that the candidate correction is a change in online information.

  • RyanWatsonRyanWatson USMember ✭✭✭

    @BrendanZagaeski Updated to 15.3.2 yesterday and now my PC cannot connect to my Mac to do builds. Would this be the same issue?

  • rseostarrseostar USUniversity ✭✭

    For anyone having this issue still, Go to your installed extensions and you should see a revert option when you click on "Xamarin.Apple SDK".
    I reverted and it works fine again.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai
    edited August 2017

    Would this be the same issue?

    • Did you check if the error message matches the first post in this thread: "The Xamarin Build Agent is not running on the Mac"?
    • Do you have the Xamarin Updater extension installed?
    • Did you run the Visual Studio 2017 version 15.3.2 update before August 22 at 22:00 UTC (the time stamp of my previous comment)?

    If the answer is "yes" to all three questions, then the chances are fairly high that you are hitting the same issue.

  • Hi.
    I'm hitting the same issue: "The Xamarin Build Agent is not running on the Mac".
    I have the Xamarin Updater extension installed.
    I run the Visual Studio 2017 version 15.3.3 update.

    I solved with the "Revert WorkAround":
    Tools -> Extentions and Updates. Then search into the list for Xamarin.Apple SDK, click on it and click on Revert.

  • BenoistLUGNIERBenoistLUGNIER FRMember ✭✭

    Hi,

    I've got the error :
    "The Xamarin Build Agent is not running on the Mac. An active Build Agent is required to perform the build".
    Tools -> extension and updates
    Find Xamarin.Apple SDK
    Click Revert.

    Everythings come back to normal.
    Thanks for solution

    Benoist

Sign In or Register to comment.