Visual Studio 2017 for MAC - Installer Hangs

Hi,

Well first thank you so much for taking the time to look at my question, I'm new here and I'm not sure if this is the correct place to ask for assistance, if not please accept my apologies, also english is not my native language so I’m sorry if my english is broken.

I've been trying to install VS for more than a week now, and I get the same problem every single time, VS hangs at accepting license terms, I can't move from that; I tried with xcode previously installed, without xcode installed, with .NET Core SDK previously installed, without .NET Core SDK, different installers, with LAN Internet Connection, with WLAN internet connection, without internet connection at all, I even formated my Mac and tried everything again and it didn't work, I contacted https://www.visualstudio.com/es/vs/support/ and spend like 2 hours in a chat with a really helpful guy who told me to post this issue here because we really tried everything.

The problem is when I click on continue after accepting the license terms it gets stuck right there, doesn't even show me the screen where I can select which options to install.

Here is the last piece of the log, after this nothing happens, it just hangs there forever

[2017-08-23 23:53:07.943] [Info] Detection complete
[2017-08-23 23:53:07.944] [Info] Initial task completed successfully
[2017-08-23 23:53:10.314] [Debug] Detection complete on the introduction page, determining the next steps.
[2017-08-23 23:53:10.314] [Debug] Starting Xcode detection
[2017-08-23 23:53:10.415] [Info] No Xcode detected.
[2017-08-23 23:53:10.415] [Info] Xcode must be installed.
[2017-08-23 23:53:10.424] [Debug] Xcode not found, need to remind

Thank you so much in advance for all the help.

Answers

  • JGoldbergerJGoldberger USMember, Forum Administrator, Xamarin Team, University Xamurai

    Well I hate to state the obvious but you did not say if you tried it. The error you posted says explicitly

    [2017-08-23 23:53:10.314] [Debug] Starting Xcode detection
    [2017-08-23 23:53:10.415] [Info] No Xcode detected.
    [2017-08-23 23:53:10.415] [Info] Xcode must be installed.

    Did you install XCode? You can install XCode from the Mac App Store. It's free.

  • @JGoldberger said:
    Well I hate to state the obvious but you did not say if you tried it. The error you posted says explicitly

    [2017-08-23 23:53:10.314] [Debug] Starting Xcode detection
    [2017-08-23 23:53:10.415] [Info] No Xcode detected.
    [2017-08-23 23:53:10.415] [Info] Xcode must be installed.

    Did you install XCode? You can install XCode from the Mac App Store. It's free.

    Yes I did, I tried with xcode, without xcode, with .NET Core SDK, without .NET Core SDK, with LAN Internet conection, with WLAN internet connection, I formated my Mac... I mean, I tried everything.

    But I did find the solution like 10 min ago, I changed my computer system language from spanish to english and it worked perfectly with the default language set to english... I got this recomendation from a guy on visual studio community who experienced exactly the same problem.

    Not sure why the installer does not work when the system language is spanish, but changing it to english solved my problem.

    Here is the link for the post I made in visual studio community: https://developercommunity.visualstudio.com/content/problem/100456/vs-for-mac-hangs-at-license-terms-installer.html

    Any way, thank you so much for taking the time to look at my post and tried to provide a solution.

  • JGoldbergerJGoldberger USMember, Forum Administrator, Xamarin Team, University Xamurai

    Oh, and you did say you tried it with XCode installed... sorry missed that. I am glad you found a solution. I had not heard of that issue with Spanish before. Definitely something that should be addressed.

  • Don't worry about it! And yes, after a week trying to find a solution, I only came across with this other guy experiencing the same problem that I was getting... so I assume it is not that common, however I do agree with you, it should be addressed.

    Thank you again for your time.

  • JGoldbergerJGoldberger USMember, Forum Administrator, Xamarin Team, University Xamurai

    The Xamarin support team is now aware of this issue and is being followed up.

  • @JGoldberger said:
    Well I hate to state the obvious but you did not say if you tried it. The error you posted says explicitly

    [2017-08-23 23:53:10.314] [Debug] Starting Xcode detection
    [2017-08-23 23:53:10.415] [Info] No Xcode detected.
    [2017-08-23 23:53:10.415] [Info] Xcode must be installed.

    Did you install XCode? You can install XCode from the Mac App Store. It's free.

    Yes I did, I tried with xcode, without xcode, with .NET Core SDK, without .NET Core SDK, with LAN Internet conection, with WLAN internet connection, I formated my Mac... I mean, I tried everything.

    But I did find the solution like 10 min ago, I changed my computer system language from spanish to english and it worked perfectly with the default language set to english... I got this recomendation from a guy on visual studio community who experienced exactly the same problem.

    Not sure why the installer does not work when the system language is spanish, but changing it to english solved my problem.

    Here is the link for the post I made in visual studio community: https://developercommunity.visualstudio.com/content/problem/100456/vs-for-mac-hangs-at-license-terms-installer.html

    Any way, thank you so much for taking the time to look at my post and tried to provide a solution.

Sign In or Register to comment.