I can't deploy my app successfully

DerstineBuyagan.5556DerstineBuyagan.5556 USMember
edited July 2017 in Visual Studio

Hi, i decided to try xamarin this past couple of days and i really don't expect how hard it is to set up in VS2017. I even reinstalled VS2017 thrice in order to get xamarin integrated to VS2017. Now, i created a blank xamarin app and try to deploy it to an emulator. I heard i need to wait because the building process take some time and i did. But it's been 20 minutes and still can't be able to see the output. Please help.

Edit: If i disconnect from the internet, the output window will show

2>emulator: WARNING: UpdateCheck: Failure: Error
2>emulator: WARNING: UpdateCheck: Failure: Error

Does this mean i need to be connected to the internet to be able to test my application?

Answers

  • NagiiNagii BRMember ✭✭

    Click the right mouse button on the project and the item of rum

  • N_BauaN_Baua INMember ✭✭✭✭✭
    edited July 2017

    @DerstineBuyagan ,

    There can be few things which could hinder the app deployment.
    Not sure exactly what is causing you so much trouble.

    Okey so no worries, try any/all of this things and if they can work you out:

    • Make sure, You are not behind firewalls or incorrect proxy's which are stopping Nugets from being updated.
    • Check that you have the complete Android SDK API level updates installed for which your simulator is trying to initiate (For example Level 19). Also check there are no Proxy's which are blocking the updates.
    • Check you're having the simulators properly configured with AVD manager and they are staring from AVD managers properly. (I can see that your simulator is launching, but still check this if required.).
    • Check the RAM allocations and other control properties are not changed initially and have default values applied.
    • If possible use the Intel HXAM (Intel x86) configurations (You need to get this separately - just google it.)
    • Un-check the fast deployment options (i.e Use shared run-time and the option below it) in the project properties.
    • Check the 'Generate one package per ABI' option and try Armeabi-v7a version with deployment (This version works with most of the simulators and generic android devices.)
    • Make sure Linking options are set to None.

    Try using alternate simulators, Like I archive the APK and deploy it in Nox Player, which is 3x to 5x faster then any standard simulator.

    Hope this helps.

    Regards,
    N Baua

  • N_BauaN_Baua INMember ✭✭✭✭✭

    @Nagii said:
    Click the right mouse button on the project and the item of rum

    Hey buddy,
    Be little more expressive, Everybody here knows how to right-click and run.
    Try to solve the problem if you really think can, else you know what not to do.

    Hope I am not being rude to you, please let us keep XF forums clean.

    Regards,
    N Baua

  • @N_Baua said:
    @DerstineBuyagan ,

    There can be few things which could hinder the app deployment.
    Not sure exactly what is causing you so much trouble.

    Okey so no worries, try any/all of this things and if they can work you out:

    • Make sure, You are not behind firewalls or incorrect proxy's which are stopping Nugets from being updated.
    • Check that you have the complete Android SDK API level updates installed for which your simulator is trying to initiate (For example Level 19). Also check there are no Proxy's which are blocking the updates.
    • Check you're having the simulators properly configured with AVD manager and they are staring from AVD managers properly. (I can see that your simulator is launching, but still check this if required.).
    • Check the RAM allocations and other control properties are not changed initially and have default values applied.
    • If possible use the Intel HXAM (Intel x86) configurations (You need to get this separately - just google it.)
    • Un-check the fast deployment options (i.e Use shared run-time and the option below it) in the project properties.
    • Check the 'Generate one package per ABI' option and try Armeabi-v7a version with deployment (This version works with most of the simulators and generic android devices.)
    • Make sure Linking options are set to None.

    Try using alternate simulators, Like I archive the APK and deploy it in Nox Player, which is 3x to 5x faster then any standard simulator.

    Hope this helps.

    Regards,
    N Baua

    Thanks buddy.


    • Make sure, You are not behind firewalls or incorrect proxy's which are stopping Nugets from being updated.

    --I am pretty sure i am not behind any proxy or firewalls. Does this mean i need always connected to internet whenever i want to debug and deploy my application? If yes, how to deploy an app when i'm offline?


    • Check that you have the complete Android SDK API level updates installed for which your simulator is trying to initiate (For example Level 19). Also check there are no Proxy's which are blocking the updates.

    --I opened SDK manager and update those which needs an update.


    • Check you're having the simulators properly configured with AVD manager and they are staring from AVD managers properly. (I can see that your simulator is launching, but still check this if required.).

    --What are the things i need to look up here?

  • N_BauaN_Baua INMember ✭✭✭✭✭
    edited July 2017

    @DerstineBuyagan.5556

    Hmm, Interesting.

    i need always connected to internet - No not really. However few times when if you are accessing any service or content from web. One more thing is the nuget package updates are checked/run frequently in back ground (and that's why we have the large packages folder in our project).

    Secondly, If you are updated on SDK front that is great. no issues here.

    Lastly What are the things i need to look up here? Please check if the AVDs are good and you can start them from AVD manager.

    Best of luck with these things and I hope the other suggestions are also being considered. Hopefully you'll be up and running soon. :smile:

    If still, you have issues further, try looking in the LogCat, that;s the best place to dig the issues.

    Regards,
    N Baua

  • @N_Baua said:
    @DerstineBuyagan.5556

    Hmm, Interesting.


    i need always connected to internet - No not really. However few times when if you are accessing any service or content from web. One more thing is the nuget package updates are checked/run frequently in back ground (and that's why we have the large packages folder in our project).


    mmpp, but when i disconnect from the internet the console window will says,
    2>emulator: WARNING: UpdateCheck: Failure: Error
    2>emulator: WARNING: UpdateCheck: Failure: Error


    Secondly, If you are updated on SDK front that is great. no issues here.

    Lastly What are the things i need to look up here? Please check if the AVDs are good and you can start them from AVD manager.


    I can start AVD successfully from the AVD Manager, i tested the VisualStudio_android-23_x86_phone and it works fine. I didn't test the other images since i don't use them.

    Best of luck with these things and I hope the other suggestions are also being considered. Hopefully you'll be up and running soon. :smile:

    If still, you have issues further, try looking in the LogCat, that;s the best place to dig the issues.

    Regards,
    N Baua

    -- I tried to use the settings u mention, it builds pretty quick but unluckily it can't still deploy the app.

    Attach here is the output log..

    log.txt 29.7K
  • N_BauaN_Baua INMember ✭✭✭✭✭

    @DerstineBuyagan.5556

    There seems to be multiple issues with this application setup and can be deeper than we think.

    • I can see INSTALL_FAILED_NO_MATCHING_ABIS in your log file.

    This error occur when you are trying to deploy an app that has native libraries which are not compatible for your device (cpu) architecture. For example if you've compiled an app for arm-v7 and are trying to install it on an emulator that uses the x86 architecture it will fail. So please make sure you are generating seperate APKs per ABI and try to install one by one, that way you'll know what's your emulator is supporting.

    • AVDs look good at a glance, I am not sure why your getting emulator: WARNING: UpdateCheck: Failure: Error

    This is generally advised as not to use proxies, however I've seen this error occurring at seldom, Make sure your Intel HAXM is properly installed and configured (check the BIOS and Hyper-V as well)

    Hope this helps.

    Regards,
    N Baua

Sign In or Register to comment.