Forum Xamarin Test Cloud (Read Only)

Why is the string in the Label property of an AppResult not queryable through Property(“label”)?

When I query with

app.Query(c=>c.Marked("02_Voided_NotReviewed"))

I get this result:

[[0] {Id => null, Description => 
"md5b60ffeb829f638581ab2bb9b1a7f4f3f.FormsImageView{d0c6be9 V.ED..... 
........ 0,0-80,80}",
Rect => {Width => 80, Height => 80, X => 0, Y => 718, CenterX => 40, CenterY 
=> 758}, 
Label => "02_Voided_NotReviewed", 
Text => null, 
Class => "md5b60ffeb829f638581ab2bb9b1a7f4f3f.FormsImageView",
Enabled => true }, ...

My first confusion is that the documentation for Marked doesn't mention it searches the "Label" property for android. So I think it should be returning 0 results, but now to the main issue. I want to use Property so I can filter more general results but i'm querying the exact string for simplicity.

When I query with

app.Query(c=>c.Property("label").Contains("02_Voided_NotReviewed"))

I get 0 results. I've tried Property("Label") and Property("label"). Contains, StartsWith, and Like also return 0 results. When I use Property("text") and query for a string the the Text property I do get results, So I think it's something to do with the label property. Has anyone else experience this issue or can see anything i'm doing wrong?

Tagged:

Best Answer

  • DevinGuthrieDevinGuthrie US ✭✭
    Accepted Answer

    Accidental duplicate of this thread. Which has been answered. Mods, feel free to delete this thread.

Answers

  • DevinGuthrieDevinGuthrie USMember ✭✭
    Accepted Answer

    Accidental duplicate of this thread. Which has been answered. Mods, feel free to delete this thread.

Sign In or Register to comment.