Xamarin IOS Build Version is not getting changed for particular project.

currently my Xamarin IOS project has build version 2.6(1.0). But while i am trying to change it to 2.6(1.0.1) its not changing. It is taking previous that is 2.6(1.0.1) and that is for only particular project. While tried same thing with another project the build version get changed. SO i am not able to figure out the problem. Is there is any way to figure out

Answers

  • JGoldbergerJGoldberger USMember, Forum Administrator, Xamarin Team, University Xamurai

    @mayurkakad.8806

    Not sure, but there is an option in the iOS project options in Visual Studio for Mac (or Xamarin Studio on Mac) to "Get version form Parent Solution." This is found in the General->Main Settings page of the Project Options. I do not see a similar option in Visual Studio (Windows) in the iOS Project Properties, but the XML element in the .csproj file for that option is:
    false.
    if the option is selected, that XML element is not in the .csproj file, it is only added if the option is not set, and it gets the value "false".

  • rajgogrirajgogri USMember

    Hi Guys. I am also facing this issue. Tried Jon's Suggestion to check the .csproj file. Get version form Parent Solution is set to true which looks fine, but when I try to create an ipa build for release version it does not catch my applied build version. Instead Xamarin replaces build version with default 1.0 , Any suggestions ?

Sign In or Register to comment.