Bug with Xamarin.Forms for UWP UI MVVM gets blank

There is a bug in Xamarin.Forms for UWP when you have a complex model with INotifyPropertyChanged in its childrens, the UI gets blank after an update.

In the attached example I create a Model with a list of childrens that have GUIDs that updates over time. If you test that in Android it works as expected. But in UWP the children gets blank after updated.

Answers

  • NMackayNMackay GBInsider, University mod

    I'd suggest testing with 2.3.5-pre6, there's tonnes of bug fixes for UWP in 2.3.5-pre, it also fixed an issue I had in UWP that a binding changing in the viewmodel wasn't reflected in the UI, it only bound when the view was 1st built. Sounds like a similar issue.

  • JoseGeraldinoJoseGeraldino USMember

    Thanks Norman.

    I will look at it.

    Thanks for your quick response.

  • JoseGeraldinoJoseGeraldino USMember

    I tested my application and now It works as expected, sadly I will need to wait for the final version to put it in production.

  • NMackayNMackay GBInsider, University mod
    edited July 2017

    @JoseGeraldino said:
    I tested my application and now It works as expected, sadly I will need to wait for the final version to put it in production.

    Us too. Although we've just about convinced the business to abandon mobile UWP as the Android low cost handsets are now only $20's more (decent handsets) and we've probably wasted a hundred man hours on UWP compatibility....users hate the Windows phone devices.

    We'll support it for tablets but really, 2.3.4-5 make Forms/UWP better but the dev cost to tweak it in comparison to iOS and Android are not good I have to admit.

Sign In or Register to comment.