Visual studio 2017 intellisense not working for axml layouts

DejanGrumDejanGrum USMember ✭✭

Hi!
I am using Visual Studio 2017 with Xamarin.Android 7.2.

Posts

  • DejanGrumDejanGrum USMember ✭✭

    I get a warning "Undefined complexType 'java.lang.Object' is used as a base for complex type extension"

  • jalle007jalle007 USMember ✭✭
    edited May 2017

    Same problem here. Neither of suggested solution worked.

  • PatyfatycakePatyfatycake NZMember ✭✭

    Happens to me too, even VS 2015.

  • Hardik_MistryHardik_Mistry USMember, University ✭✭✭

    @DejanGrum @jalle007

    • Navigate to root of your project
    • Delete the .vs folder (hidden folder)
    • Restart VS
    • Open solution

    Try and share your thoughts if that works.

  • PatyfatycakePatyfatycake NZMember ✭✭

    @HardikAnantMistry said:
    @DejanGrum @jalle007

    • Navigate to root of your project
    • Delete the .vs folder (hidden folder)
    • Restart VS
    • Open solution

    Try and share your thoughts if that works.

    Doesn't work.

  • Hardik_MistryHardik_Mistry USMember, University ✭✭✭
    edited May 2017

    @Patyfatycake

    Try the reference: https://developer.xamarin.com/guides/android/troubleshooting/questions/enable-axml-intellisense/

    Can you verify if Android SDK Tools, Android SDK Platform-Tools and Android SDK Build-Tools are updated to latest version as well?

    Must have done that, but may be give it a try.

  • DejanGrumDejanGrum USMember ✭✭

    @HardikAnantMistry said:
    @DejanGrum @jalle007

    Navigate to root of your project
    Delete the .vs folder (hidden folder)
    Restart VS
    Open solution
    Try and share your thoughts if that works.

    Doesn't work for me too and everything is up to date.

  • PatyfatycakePatyfatycake NZMember ✭✭

    Of course I tried that reference, many times infact and I do have the latest build tools.

  • JonDouglasJonDouglas USXamarin Team, University, Developer Group Leader Xamurai

    Hi All,

    I believe this is an issue with a recent bug in the xml parser. I believe it will be fixed in time for the 15.3 release.

  • PatyfatycakePatyfatycake NZMember ✭✭

    @JonDouglas said:
    Hi All,

    I believe this is an issue with a recent bug in the xml parser. I believe it will be fixed in time for the 15.3 release.

    Thanks for the headsup. I don't want to be "that guy" but do you have an eta on that release? EG a week or 2 to a month?

  • ccamiloccamilo FIMember

    I have the same issue. In the past I fixed by doing what is described here: https://forums.xamarin.com/discussion/comment/261778#Comment_261778
    But now, not even that works. I don't have any intellisense.

  • SAthukoraleSAthukorale USMember ✭✭
    edited May 2017

    Just use Xamarin Studio (not VS). I faced the same issue from time to time. It would work, suddenly it won't. I ended up using Xamarin Studio (and am still) and IntelliSense works perfectly if not even better.

  • JonDouglasJonDouglas USXamarin Team, University, Developer Group Leader Xamurai

    @Patyfatycake

    15.2 will release shortly. After that, will be 15.3 in June. You can estimate about a month between each release based on the VS history:

    https://www.visualstudio.com/en-us/news/releasenotes/vs2017-relnotes

  • RaymondArvidssonRaymondArvidsson SEMember ✭✭

    So what U saying is that 15.3 is the solution?? What do we do until then??

  • JonDouglasJonDouglas USXamarin Team, University, Developer Group Leader Xamurai

    I can confirm that Xamarin 4.5.0.486 using Xamarin.Android SDK 7.3.1.2 seems to solve the XML intellisense issues. Please upgrade to this version and let me know if it works for you.

  • Faiz.7125Faiz.7125 INMember
    @JonDouglas Does not work for me.
  • JonDouglasJonDouglas USXamarin Team, University, Developer Group Leader Xamurai

    @Faiz.7125 Please post your Version Information so I can confirm.

  • Faiz.7125Faiz.7125 INMember
    edited June 2017

    Xamarin v4.5.0.486 and Xamarin Android SDK 7.3.1.2. I installed Xamarin Studio for now. but I am used to visual studio any other suggestion or could you please confirm if *.axml intellisense works in the latest beta

  • Faiz.7125Faiz.7125 INMember
    @JonDouglas could you please confirm if it works in the latest beta
Sign In or Register to comment.