First app closes automatically. No package specified warning

zoloxinzoloxin ESMember

Hi,

I'm new into Xamarin so I installed the platform and started following the guide and I made the phoneword example https://developer.xamarin.com/guides/android/getting_started/hello,android/hello,android_quickstart/

When trying to deploy in mobile (API22) it opens a black screen and closes the app in less than a second, the same happens if a install the app on my phone manually. If I try with the 2 android emulator I get black screens and the app doesn't execute
I'ried with a a blank application and the result is the same

This the output I get

1>Error: no package specified

The application could not be started. Ensure that the application has been installed to the target device and has a launchable activity (MainLauncher = true).

And then no package specified warning appears:

In Xamarin diagnostics appears this:
Mono.AndroidTools.InstallFailedException: Unexpected install output: pkg: /data/local/tmp/Mono.Android.DebugRuntime-debug.apk
Failure [INSTALL_CANCELED_BY_USER]

I've tried debug and release and reinstalling Xamarin with the same result.
I use Windows 10 with Visual studio 2015

I don't know how to solve this, any idea?

Thank
Regards

Answers

  • kentuckerkentucker USMember ✭✭✭✭✭

    If you are running the hyper-v android emulators I would close the emulator and open up the hyper-v manager on your computer. In the settings for the emulator you are trying to run make sure the compatibility check box is checked under processor

  • zoloxinzoloxin ESMember

    Thanks for the answer.

    I've installed visual studio 2015 update3 and the problem remains.
    I'm using Android_Accelerated_x86 and ARMv7a.
    I don't think it is a problem about the emulator because the same happens with physical devices.

    Any idea?

  • jesuslg123xjesuslg123x ESMember

    Hi,

    This is happening to me now, just for real devices, emulators works propoertly.

    Any idea?

  • zoloxinzoloxin ESMember
    I couldn't make it work :(
Sign In or Register to comment.