Forum Xamarin Test Cloud (Read Only)


The Xamarin Forums have officially moved to the new Microsoft Q&A experience. Microsoft Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

To create new threads and ask questions head over to Microsoft Q&A for .NET and get involved today.

Why do I get a TrustFailure when using test-cloud.exe on Windows 10


I am trying to run a test via the command line.
I am using VS 2017 and I have also installed Mono for windows (64).

To run the test I start Mono and type:


mono D:\tfs\XamarinDevelopment\SandboxTestAndroid\packages\Xamarin.UITest.1.3.8\tools\test-cloud.exe submit D:\Xamarin\MyApk.apk000my.API.Key000 --devices 0bc9c9a6 --series "master" --locale "en_US" --app-name "Sandbox.Android" --user [email protected] --assembly-dir  D:\tfs\XamarinDevelopment\SandboxTestAndroid\SandboxTestAndroid\bin\Debug

When I run this I get the following error:

Negotiating file upload to Xamarin Test Cloud.
Retrying in 10 seconds. Failed to reach server: WebException: Error: TrustFailure (The authentication or decryption has failed.)

I have tried a similar test on my Mac and it uploads OK.
I believe my firewall settings (as specified by Xamarin) are correct.

Can someone explain why I'm getting this and how I can solve it.


Best Answer

  • SeanConlonSeanConlon USMember ✭✭
    Accepted Answer

    Solution is to remove the word "Mono" from the start of the line :)


Sign In or Register to comment.