.ipa file not linked with Calabash

Hello

I've written my xamarin.uitests and successfully excuted them locally for both Android and iOS platforms. However although the Android tests work in the Xamarin Test Cloud I am experiencing an issue with the iOS execution. I recieve the message

'The .ipa file does not seem to be linked with Calabash framework'

I've looked through the documentation but I can't find anything relating to this error. Does anyone have any suggestions on solving this problem?

Thanks

MITL

Best Answer

  • ManInTheLoftManInTheLoft GB ✭✭
    edited January 2016 Accepted Answer

    Solved it. I had a semi colon in the complier directive so instead of

    DEBUG;ENABLE_TEST_CLOUD;

    I had

    DEBUG:ENABLE_TEST_CLOUD;

    Consequently

    if ENABLE_TEST_CLOUD
    Xamarin.Calabash.Start();
    endif

    was never executed. Simple in the end!

    MITL

Answers

  • ManInTheLoftManInTheLoft GBBeta, University ✭✭
    edited January 2016 Accepted Answer

    Solved it. I had a semi colon in the complier directive so instead of

    DEBUG;ENABLE_TEST_CLOUD;

    I had

    DEBUG:ENABLE_TEST_CLOUD;

    Consequently

    if ENABLE_TEST_CLOUD
    Xamarin.Calabash.Start();
    endif

    was never executed. Simple in the end!

    MITL

  • AnthonyMehallelAnthonyMehallel USMember ✭✭✭
    edited January 2016

    Hello Man In The Loft,

    I have exactly the same problem as you .

    Please, Can you describe, step by step, the resolution of this problem ?

    Thank you,
    Anthony M.

  • ManInTheLoftManInTheLoft GBBeta, University ✭✭

    @AnthonyMehallel - I've PM'd you a rough guide. Let me know how it goes.

    MITL

  • AnthonyMehallelAnthonyMehallel USMember ✭✭✭

    @ManInTheLoft , Yes Thanks ! I just answer in MP.

    Anthony M.

  • @ManInTheLoft can you please post the resolution here as well

  • ChristoNelChristoNel USMember ✭✭

    This was my problem:

    Navigate to YOUR_SOLUTION -> Options -> Compiller and select the debug configuration.
    Set the device as iPhone.

    Now you should see ENABLE_TEST_CLOUD as a Debug directive, if its not there then add it or else the code:

    if ENABLE_TEST_CLOUD
    Xamarin.Calabash.Start();
    endif

    wil not execute at all causing that error to be thrown.

    Make sure to add it with a semi colon.

  • GupthaGuptha USMember ✭✭

    @ManInTheLoft
    can you please post the resolution here as well

  • PallaviDPallaviD USUniversity
    edited November 2016

    In xamarin test cloud, my error went, when I put my ios file to debug|iphone, compile whole solution, I removed .AppBundle step from BeforeEachTest() step as my UITest project is part of solution, and I added ios project in Unit test window (I am using Xamarin studio on Mac machine).
    then I submitted test after compilation to run on Xamarin test cloud.

    I was also needed to put this variable in compiler attribute in debug configuration, thanks! >>

    "
    @ManInTheLoft said:
    Solved it. I had a semi colon in the complier directive so instead of

    » show previous quotes
    I had

    » show previous quotes
    Consequently

    » show previous quotes
    was never executed. Simple in the end!

    MITL"

  • PallaviDPallaviD USUniversity

    @ManInTheLoft said:
    Solved it. I had a semi colon in the complier directive so instead of

    DEBUG;ENABLE_TEST_CLOUD;

    I had

    DEBUG:ENABLE_TEST_CLOUD;

    Consequently

    if ENABLE_TEST_CLOUD
    Xamarin.Calabash.Start();
    endif

    was never executed. Simple in the end!

    MITL

    I was also needed to put this variable in compiler attribute in debug configuration, thanks!

  • shubbyshubby USMember

    @ChristoNel said:
    This was my problem:

    Navigate to YOUR_SOLUTION -> Options -> Compiller and select the debug configuration.
    Set the device as iPhone.

    Now you should see ENABLE_TEST_CLOUD as a Debug directive, if its not there then add it or else the code:

    if ENABLE_TEST_CLOUD
    Xamarin.Calabash.Start();
    endif

    wil not execute at all causing that error to be thrown.

    Make sure to add it with a semi colon.

    I dont see ENABLE_TEST_CLOUD option in my compiler.
    How can i get that?

  • ManInTheLoftManInTheLoft GBBeta, University ✭✭
    edited June 2017

    @Subby

    Navigate and select the project (not solution) -> right click and select options -> select compiler -> in the section 'Define Symbols' ensure the entry 'ENABLE_TEST_CLOUD;' is present. You'll probably also have 'DEBUG;'. Don't forget the semicolons ';'. You have to physically type these values in the section.

    MITL

  • ChristoNelChristoNel USMember ✭✭
    edited June 2017

    @Subby

    Once your on the "Compiller" tab inside the Options window, make sure your configuration is set to Debug.
    You should see a label saying "Define Symbols:" inside this window with a TextField next to it.

    If you don't have the "ENABLE_TEST_CLOUD" symbol there just add it and remember the semi-colons.

    Here is a screenshot for you of what mine looks like:

Sign In or Register to comment.