Unable to connect to Android emulator

SuatKorkmazSuatKorkmaz Suat KorkmazUSMember ✭✭✭
edited June 1 in Xamarin.Android

I've updated Xamarin for VS2015 to the latest stable (4.5.0.476) and I'm getting the error attached.

I'm using is the generic emulators that comes with Android SDK.

Anyone else have this?

Answers

  • DhilluDhillu Dhilleswar Nayudu INMember ✭✭✭

    Earlier I had same problem. I installed VisualStudio Emulator for Android and it's running good.
    Found VSEmulator is far better then the emulators come with SDK.

  • SuatKorkmazSuatKorkmaz Suat Korkmaz USMember ✭✭✭

    OK I just installed VSEmulator and tried. I started an emulator manually. The VS debugger just can't connect to it. It can't even install the app to the emulator. VS seem to be running but nothing happens.

    Should I re-install the mono debugger?

  • SuatKorkmazSuatKorkmaz Suat Korkmaz USMember ✭✭✭

    OK it didn't help.

  • PhilippSumiPhilippSumi Philipp Sumi USMember ✭✭✭

    I think the hanging VS with the emulator (VS just sits there during deployment of the apk to the emulator, but nothing actually happens) is another issue - I've had that for weeks if not months.

  • AicBodAicBod antonio infante USMember ✭✭

    Solved. visual studio 2015.

    1. Copy Mono.Posix.dll into C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\Extensions\Xamarin\Xamarin

    2. Open Mono.Posix.dll properties and mark the checkbox "Unblock" in "General" tab. Then click "Apply" and "OK".

    3. change deven.exe.config

    path: C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\deven.exe.config
    add this property


    1. close and Reopen Visual Studio.
Sign In or Register to comment.