Forum Xamarin.iOS
We are excited to announce that the Xamarin Forums are moving to the new Microsoft Q&A experience. Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

We encourage you to head over to Microsoft Q&A for .NET for posting new questions and get involved today.

while running in aot-only mode

TapasBeheraTapasBehera USMember ✭✭

The application was running fine.But I started getting this runtime error recently.

Attempting to JIT compile method 'AcuantMobileSDK.AcuantMobileSDKController:ActivateLicenseKey (string)' while running in aot-only mode. See for more information.



  • Parag_JoshiParag_Joshi USMember

    I have the same issue. Application was running fine and now it generates an error instantiating a objective c library. Execution fails creating the instance:

    Attempting to JIT compile method 'Method Name Here:.ctor ()' while running in aot-only mode. See for more information.

    It also seems this issue was addressed a while ago. Perhaps issue has resurfaced?

  • AdamLangleyAdamLangley NZMember ✭✭

    This appears to be a regression - I have just upgrade to Xamarin iOS, and now I am getting this on my custom binding lib also. I'm going to have to go back to previous stable - this is actually my second attempt at - the last time I went back I lost debug breakpoints, and the Forms designer - so this is killing my productivity.

    Can anyone at Xamarin comment?

  • MugsMugs USMember ✭✭

    I am having the same problem, it was working fine until a few days ago, now Attempting to JIT compile method while running in aot-only mode.

    Tryied using the --registrar flags but still no success...

    Can someone take a look at this?

  • MugsMugs USMember ✭✭

    I tried using Link behavior: Don't Link as mrmiagi0101 said on the following post:

    It is now working for me.

  • ksachdevaksachdeva USMember ✭✭

    Same problem. Project was working fine; updated to VS for Mac and now throwing the same error as mentioned in this post

  • Sledgehammer777Sledgehammer777 USUniversity ✭✭

    I just upgraded to the latest Stable releases and now I get this similar error on the LoadApplication(new App()) call in the AppDelegate class.

Sign In or Register to comment.