WebApi Not Working?

KiranRandhawaKiranRandhawa GBMember

Hello all,

Apologies if this question does not belong in general discussion. I couldn't find a section that best described this problem.

I created a Web API project in visual studio which I successfully ran it using Xamarin Studio on Windows.

I switched to Mac OS X and fired up the project in Xamarin Studio. When I ran the webApi project I got the following error:

System.TypeLoadException
A type load exception has occurred.

Description: HTTP 500. Error processing request.

Details: Non-web exception. Exception origin (name of application or object): HandsomeDevelopers.WebApi.

Exception stack trace:
at HandsomeDevelopers.WebApi.WebApiApplication.Application_Start () [0x00006] in /Users/kiranrandhawa/Desktop/HandsomeDevelopers/HandsomeDevelopers.WebApi/Global.asax.cs:21
at (wrapper managed-to-native) System.Reflection.MonoMethod:InternalInvoke (System.Reflection.MonoMethod,object,object[],System.Exception&)
at System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00054] in /private/tmp/source-mono-mac-4.0.0-branch/bockbuild-mono-4.0.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.0.1/mcs/class/corlib/System.Reflection/MonoMethod.cs:230

Version Information: 4.0.1 ((detached/ed1d3ec Tue May 26 17:22:37 EDT 2015); ASP.NET Version: 4.0.30319.17020

It appears that Xamarin Studio could not run the WebApi project on OSX.

First of all does anyone have a solution to this problem?

Secondly I wondered if it's possible to create a WebApi project using Xamarin Studio? Does anyone have any tutorials?

Any help would be greatly appreciated!

Many Thanks,
Kiran

Tagged:

Posts

  • Piyu22Piyu22 INMember

    I know this is older post.But did you get any solution for this? :|

Sign In or Register to comment.