Forum Visual Studio

Mac Agent Stopped Working After Network Change?

dstarnesdstarnes USMember ✭✭

On Thursday morning everything was working just fine. I could use VS 2017 with Xamarin and all was well. The Mac Agent faithfully connected to my Mac every time. Then I presented the new VS2017 and VS4Mac features at our local user group Thursday night. Ever since then, the Mac Agent will sometimes see the name of my Mac on the network and will never connect. I can still SSH into the Mac from the PC so I know that's working. I also know that the Mac Agent is authenticating with with username and password because if a give it a fake username and password it gives me an error about invalid credentials. I have also removed VS4Mac (Preview 5) from my machine and restarted and tried everything with brand new projects with no success. I've seen some similar bugs regarding VS4Mac but they were after the Mac Agent had actually connected. I don't think it has anything to do with the network change at the UG location but that's all I can think of. Are there any other ideas that I haven't looked into?



  • dstarnesdstarnes USMember ✭✭

    UPDATE: I have confirmed with netstat that an SSH connection has been made between the two machines. Also, I have tried setting UseDNS in sshd_config to No and that had no effect. I thought maybe Bonjour isn't running but mDNSResponder is up so I'm still at a loss.

  • dstarnesdstarnes USMember ✭✭

    UPDATE: There are a number of lines in /var/log/system.log reading:

    Service exited with abnormal code: 255

    For the sshd service but the surrounding lines provide no clue as to why the error was caused.

  • chuckctichuckcti USMember ✭✭

    Have you had any luck with this? I had the Mac Agent working fine over in both internal IP and public IP/port forwarding configurations. I left for a couple weeks of vacation, and the publicIP/port forwarding config no longer works. I can still ssh to the Mac via the public configuration, but Xamarin also gives the invalid credentials message.

Sign In or Register to comment.