Forms Previewer take too much of CPU and memory

SyooianSyooian USMember
edited March 2017 in Xamarin.Forms

Hello,

Today I install the latest VS2017 Community and open a new .Forms project, and I find that if you open the Forms Previewer and editting your .xaml file for a while, the memory usage is going higher and higher, and CPU is full running, this cause my PC so slow, if I want to stop this is close the VS now, or just don't do anything for a while, and this situation will return normal. I don't know what just happen.

Sorry for my bad English :neutral:

Java : 1.8.0_111 x64
OS : Win10 Pro x64

Posts

  • chrisgatechrisgate NGMember

    Mine refused to work.....can u share setting?

    Thanks

  • SyooianSyooian USMember

    @chrisgate said:
    Mine refused to work.....can u share setting?

    Thanks

    Hi chrisgate,
    Do you mean my Xamarin option setting?

    I just set the 64bit JDK, Android NDK(didn't change it because already set when Xamarin installed) and update the Android SDK

  • xsxxsx USMember ✭✭

    I am also having this exact problem. Any solution yet? I even reinstalled Windows 10 + Visual Studio 2017.
    OS : Win10 Pro x64
    CPU: Intel Core I7 6700K

    Any help would be very much appreciated!

  • N_BauaN_Baua INMember ✭✭✭✭✭

    Hi,

    Try changing the process affinity, sure this may not help a lot with faster previews, however you should be safe on the CPU over consumption over 90% part.

    I am sure the deploying too often on simulator is painful and live preview is always better, however I find nox player much better with this regards, I guess less worried at-least for Android with it when I can check the APK right away.

    Hope this helps.

    Regards
    N Baua

Sign In or Register to comment.