Is FCM libraries are compatible with Xamarin Android 4.4.

I am trying to use FCM for android in xamarin. Do we have libraries for it.

Answers

  • MassimoCaroliMassimoCaroli ITMember ✭✭

    Mee too, I'm having issue with FCM on android 4.4. Works fine on 5+

    Thanks

  • cwphillicwphilli USMember ✭✭✭

    Yes we have libraries for it, what issues are you having? I am using in my packages.config:
    <package id="Xamarin.Firebase.Common" version="42.1001.0" targetFramework="monoandroid71" />
    <package id="Xamarin.Firebase.Iid" version="42.1001.0" targetFramework="monoandroid71" />
    <package id="Xamarin.Firebase.Messaging" version="42.1001.0" targetFramework="monoandroid71" />

  • cwphillicwphilli USMember ✭✭✭
    edited May 2017

    Project Properties -> Application:

  • shaiifrachshaiifrach ILMember ✭✭

    Hi @cwphilli I don't mean to hijack this thread but can you please see if you can help me with my issue
    https://forums.xamarin.com/discussion/94901/adding-firebase-ads-to-android-project-in-visual-studio#latest
    Ever since i added the firebase ads component my project is messed up
    I can't build in release mode i get the following error
    1>C:\Program Files\Microsoft Visual Studio\2017\Community\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(2025,3): error MSB6006: "java.exe" exited with code 1.

    when i open the manifest xml i get red lines under all the attributes as if their not recognized

    I can still build in debug mode and run it but with the warning i mentioned in the above linked thread and not seeing ads of course

  • cwphillicwphilli USMember ✭✭✭

    @shaiifrach I'll respond on your thread.

Sign In or Register to comment.