Forum Visual Studio
We are excited to announce that the Xamarin Forums are moving to the new Microsoft Q&A experience. Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

We encourage you to head over to Microsoft Q&A for .NET for posting new questions and get involved today.

Unable to Debug Android Apps in the Android Emulator

PatrickKellyPatrickKelly USUniversity ✭✭

Hi,
About a month ago, I was no longer able to debug my Android apps in the Emulator (the google Emulator I believe - I can't use the Xamarin Android Emulator because I use VPN).
What happens is: I can see the device in the Dropdown - I can click debug - It will properly deploy the app to the device and everything looks good until the App Starts on the device and then Visual Studio drops out of debugger mode. The app works fine on the device, it's just that it's not connected to the debugger anymore.
All build settings are the same as they were, all appropriate boxes are checked.

Anyone have any ideas on troubleshooting this? Should I re-install Xamarin? Re-install the Android portion? Is there something else I can do?
Debugging any other type of solution still works, IOS still works, my normal .NET apps still work, it's just the Android ones.

Answers

  • PatrickKellyPatrickKelly USUniversity ✭✭

    FYI, this was happening in Visual Studio 2013. Just did a new install of Visual Studio 2015 and it has the same issue.

  • FrenchfasoFrenchfaso ITBeta
    edited January 2017

    Same problem here, but with Xamarin Studio for Mac.
    Did you manage to solve this issue?
    Btw, on my setup it happens only with a 2.3 emulator image, debugging on newer Android emulator images works fine.
    I created a thread here:
    https://forums.xamarin.com/discussion/86064/unable-to-debug-blank-app-on-android-2-3-emulator-the-connection-with-the-debugger-has-been-lost#latest

  • GovaGova USMember ✭✭

    I think I found the answer. Please follow the steps below:
    1. Right click on your Droid project and go to properties
    2. Click on 'Android Option' from the left menu
    3. Under the 'Packaging' tab, make sure that 'Use Shared Runtime', 'Use Fast Deployment' and 'Enable developer instrumentation' check boxes are checked.
    4. Now save and run, project is ready to debug in emulator as well in device.
    5. Please refer the below screen shot for more info.

Sign In or Register to comment.